Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2277-1: moderate: Security update for putty
openSUSE Security Update: Security update for putty
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2277-1
Rating: moderate
References: #1152753
Cross-References: CVE-2019-17068 CVE-2019-17069
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for putty to version 0.73 fixes the following issues:

- CVE-2019-17068: Fixed the insufficient handling of terminal escape
sequences, that should delimit the pasted data in bracketed paste mode
(boo#1152753).
- CVE-2019-17069: Fixed a possible information leak caused by SSH-1
disconnection messages (boo#1152753).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2277=1



Package List:

- openSUSE Leap 15.1 (x86_64):

putty-0.73-lp151.3.6.1
putty-debuginfo-0.73-lp151.3.6.1
putty-debugsource-0.73-lp151.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-17068.html
https://www.suse.com/security/cve/CVE-2019-17069.html
https://bugzilla.suse.com/1152753

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages