Mailinglist Archive: opensuse-security-announce (40 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2269-1: moderate: Security update for openssl-1_0_0
openSUSE Security Update: Security update for openssl-1_0_0
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2269-1
Rating: moderate
References: #1131291 #1150003 #1150250
Cross-References: CVE-2019-1547 CVE-2019-1563
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for openssl-1_0_0 fixes the following issues:

OpenSSL Security Advisory [10 September 2019]

* CVE-2019-1547: Added EC_GROUP_set_generator side channel attack
avoidance. (bsc#1150003)
* CVE-2019-1563: Fixed Bleichenbacher attack against cms/pkcs7 encryption
transported key (bsc#1150250)

In addition fixed invalid curve attacks by validating that an EC point
lies on the curve (bsc#1131291).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2269=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libopenssl-1_0_0-devel-1.0.2p-lp151.5.10.1
libopenssl1_0_0-1.0.2p-lp151.5.10.1
libopenssl1_0_0-debuginfo-1.0.2p-lp151.5.10.1
libopenssl1_0_0-hmac-1.0.2p-lp151.5.10.1
libopenssl1_0_0-steam-1.0.2p-lp151.5.10.1
libopenssl1_0_0-steam-debuginfo-1.0.2p-lp151.5.10.1
openssl-1_0_0-1.0.2p-lp151.5.10.1
openssl-1_0_0-cavs-1.0.2p-lp151.5.10.1
openssl-1_0_0-cavs-debuginfo-1.0.2p-lp151.5.10.1
openssl-1_0_0-debuginfo-1.0.2p-lp151.5.10.1
openssl-1_0_0-debugsource-1.0.2p-lp151.5.10.1

- openSUSE Leap 15.1 (x86_64):

libopenssl-1_0_0-devel-32bit-1.0.2p-lp151.5.10.1
libopenssl1_0_0-32bit-1.0.2p-lp151.5.10.1
libopenssl1_0_0-32bit-debuginfo-1.0.2p-lp151.5.10.1
libopenssl1_0_0-hmac-32bit-1.0.2p-lp151.5.10.1
libopenssl1_0_0-steam-32bit-1.0.2p-lp151.5.10.1
libopenssl1_0_0-steam-32bit-debuginfo-1.0.2p-lp151.5.10.1

- openSUSE Leap 15.1 (noarch):

openssl-1_0_0-doc-1.0.2p-lp151.5.10.1


References:

https://www.suse.com/security/cve/CVE-2019-1547.html
https://www.suse.com/security/cve/CVE-2019-1563.html
https://bugzilla.suse.com/1131291
https://bugzilla.suse.com/1150003
https://bugzilla.suse.com/1150250

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages