Mailinglist Archive: opensuse-security-announce (95 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2212-1: moderate: Security update for libopenmpt
openSUSE Security Update: Security update for libopenmpt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2212-1
Rating: moderate
References: #1143578 #1143581 #1143582 #1143584
Cross-References: CVE-2018-20860 CVE-2018-20861 CVE-2019-14382
CVE-2019-14383
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for libopenmpt fixes the following issues:

Security issues fixed:

- CVE-2018-20861: Fixed crash with certain malformed custom tunings in
MPTM files (bsc#1143578).
- CVE-2018-20860: Fixed crash with malformed MED files (bsc#1143581).
- CVE-2019-14383: Fixed J2B that allows an assertion failure during file
parsing with debug STLs (bsc#1143584).
- CVE-2019-14382: Fixed DSM that allows an assertion failure during file
parsing with debug STLs (bsc#1143582).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2212=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libmodplug-devel-0.3.17-lp150.7.1
libmodplug1-0.3.17-lp150.7.1
libmodplug1-debuginfo-0.3.17-lp150.7.1
libopenmpt-debugsource-0.3.17-lp150.7.1
libopenmpt-devel-0.3.17-lp150.7.1
libopenmpt0-0.3.17-lp150.7.1
libopenmpt0-debuginfo-0.3.17-lp150.7.1
libopenmpt_modplug1-0.3.17-lp150.7.1
libopenmpt_modplug1-debuginfo-0.3.17-lp150.7.1
openmpt123-0.3.17-lp150.7.1
openmpt123-debuginfo-0.3.17-lp150.7.1

- openSUSE Leap 15.0 (x86_64):

libmodplug1-32bit-0.3.17-lp150.7.1
libmodplug1-32bit-debuginfo-0.3.17-lp150.7.1
libopenmpt0-32bit-0.3.17-lp150.7.1
libopenmpt0-32bit-debuginfo-0.3.17-lp150.7.1
libopenmpt_modplug1-32bit-0.3.17-lp150.7.1
libopenmpt_modplug1-32bit-debuginfo-0.3.17-lp150.7.1


References:

https://www.suse.com/security/cve/CVE-2018-20860.html
https://www.suse.com/security/cve/CVE-2018-20861.html
https://www.suse.com/security/cve/CVE-2019-14382.html
https://www.suse.com/security/cve/CVE-2019-14383.html
https://bugzilla.suse.com/1143578
https://bugzilla.suse.com/1143581
https://bugzilla.suse.com/1143582
https://bugzilla.suse.com/1143584

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages