Mailinglist Archive: opensuse-security-announce (95 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2205-1: moderate: Security update for expat
openSUSE Security Update: Security update for expat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2205-1
Rating: moderate
References: #1149429
Cross-References: CVE-2019-15903
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for expat fixes the following issues:

Security issues fixed:

- CVE-2019-15903: Fixed heap-based buffer over-read caused by crafted XML
input. (bsc#1149429)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2205=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

expat-2.2.5-lp151.3.6.1
expat-debuginfo-2.2.5-lp151.3.6.1
expat-debugsource-2.2.5-lp151.3.6.1
libexpat-devel-2.2.5-lp151.3.6.1
libexpat1-2.2.5-lp151.3.6.1
libexpat1-debuginfo-2.2.5-lp151.3.6.1

- openSUSE Leap 15.1 (x86_64):

expat-32bit-debuginfo-2.2.5-lp151.3.6.1
libexpat-devel-32bit-2.2.5-lp151.3.6.1
libexpat1-32bit-2.2.5-lp151.3.6.1
libexpat1-32bit-debuginfo-2.2.5-lp151.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-15903.html
https://bugzilla.suse.com/1149429

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages