Mailinglist Archive: opensuse-security-announce (95 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2062-1: important: Security update for postgresql10
openSUSE Security Update: Security update for postgresql10
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2062-1
Rating: important
References: #1145092
Cross-References: CVE-2019-10208
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for postgresql10 fixes the following issues:

Security issue fixed:

- CVE-2019-10208: Fixed arbitrary SQL execution via suitable SECURITY
DEFINER function under the identity of the function owner (bsc#1145092).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2062=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2062=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libecpg6-10.10-lp151.2.6.1
libecpg6-debuginfo-10.10-lp151.2.6.1
libpq5-10.10-lp151.2.6.1
libpq5-debuginfo-10.10-lp151.2.6.1
postgresql10-10.10-lp151.2.6.1
postgresql10-contrib-10.10-lp151.2.6.1
postgresql10-contrib-debuginfo-10.10-lp151.2.6.1
postgresql10-debuginfo-10.10-lp151.2.6.1
postgresql10-debugsource-10.10-lp151.2.6.1
postgresql10-devel-10.10-lp151.2.6.1
postgresql10-devel-debuginfo-10.10-lp151.2.6.1
postgresql10-plperl-10.10-lp151.2.6.1
postgresql10-plperl-debuginfo-10.10-lp151.2.6.1
postgresql10-plpython-10.10-lp151.2.6.1
postgresql10-plpython-debuginfo-10.10-lp151.2.6.1
postgresql10-pltcl-10.10-lp151.2.6.1
postgresql10-pltcl-debuginfo-10.10-lp151.2.6.1
postgresql10-server-10.10-lp151.2.6.1
postgresql10-server-debuginfo-10.10-lp151.2.6.1
postgresql10-test-10.10-lp151.2.6.1

- openSUSE Leap 15.1 (x86_64):

libecpg6-32bit-10.10-lp151.2.6.1
libecpg6-32bit-debuginfo-10.10-lp151.2.6.1
libpq5-32bit-10.10-lp151.2.6.1
libpq5-32bit-debuginfo-10.10-lp151.2.6.1

- openSUSE Leap 15.1 (noarch):

postgresql10-docs-10.10-lp151.2.6.1

- openSUSE Leap 15.0 (i586 x86_64):

libecpg6-10.10-lp150.3.13.1
libecpg6-debuginfo-10.10-lp150.3.13.1
libpq5-10.10-lp150.3.13.1
libpq5-debuginfo-10.10-lp150.3.13.1
postgresql10-10.10-lp150.3.13.1
postgresql10-contrib-10.10-lp150.3.13.1
postgresql10-contrib-debuginfo-10.10-lp150.3.13.1
postgresql10-debuginfo-10.10-lp150.3.13.1
postgresql10-debugsource-10.10-lp150.3.13.1
postgresql10-devel-10.10-lp150.3.13.1
postgresql10-devel-debuginfo-10.10-lp150.3.13.1
postgresql10-plperl-10.10-lp150.3.13.1
postgresql10-plperl-debuginfo-10.10-lp150.3.13.1
postgresql10-plpython-10.10-lp150.3.13.1
postgresql10-plpython-debuginfo-10.10-lp150.3.13.1
postgresql10-pltcl-10.10-lp150.3.13.1
postgresql10-pltcl-debuginfo-10.10-lp150.3.13.1
postgresql10-server-10.10-lp150.3.13.1
postgresql10-server-debuginfo-10.10-lp150.3.13.1
postgresql10-test-10.10-lp150.3.13.1

- openSUSE Leap 15.0 (x86_64):

libecpg6-32bit-10.10-lp150.3.13.1
libecpg6-32bit-debuginfo-10.10-lp150.3.13.1
libpq5-32bit-10.10-lp150.3.13.1
libpq5-32bit-debuginfo-10.10-lp150.3.13.1

- openSUSE Leap 15.0 (noarch):

postgresql10-docs-10.10-lp150.3.13.1


References:

https://www.suse.com/security/cve/CVE-2019-10208.html
https://bugzilla.suse.com/1145092

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages