Mailinglist Archive: opensuse-security-announce (90 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1904-1: important: Security update for pdns
openSUSE Security Update: Security update for pdns
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1904-1
Rating: important
References: #1138582 #1142810
Cross-References: CVE-2019-10162 CVE-2019-10163 CVE-2019-10203

Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for pdns fixes the following issues:

Security issues fixed:

- CVE-2019-10203: Updated PostgreSQL schema to address a possible denial
of service by an authorized user by inserting a crafted record in a
MASTER type zone under their control. (boo#1142810)
- CVE-2019-10162: Fixed a denial of service but when authorized user to
cause the server to exit by inserting a crafted record in a MASTER type
zone under their control. (boo#1138582)
- CVE-2019-10163: Fixed a denial of service of slave server when an
authorized master server sends large number of NOTIFY messages.
(boo#1138582)

Non-security issues fixed:

- Enabled the option to disable superslave support.
- Fixed `pdnsutil b2b-migrate` to not lose NSEC3 settings.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1904=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1904=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1904=1



Package List:

- openSUSE Leap 15.1 (x86_64):

pdns-4.1.8-lp151.2.3.1
pdns-backend-geoip-4.1.8-lp151.2.3.1
pdns-backend-geoip-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-godbc-4.1.8-lp151.2.3.1
pdns-backend-godbc-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-ldap-4.1.8-lp151.2.3.1
pdns-backend-ldap-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-lua-4.1.8-lp151.2.3.1
pdns-backend-lua-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-mydns-4.1.8-lp151.2.3.1
pdns-backend-mydns-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-mysql-4.1.8-lp151.2.3.1
pdns-backend-mysql-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-postgresql-4.1.8-lp151.2.3.1
pdns-backend-postgresql-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-remote-4.1.8-lp151.2.3.1
pdns-backend-remote-debuginfo-4.1.8-lp151.2.3.1
pdns-backend-sqlite3-4.1.8-lp151.2.3.1
pdns-backend-sqlite3-debuginfo-4.1.8-lp151.2.3.1
pdns-debuginfo-4.1.8-lp151.2.3.1
pdns-debugsource-4.1.8-lp151.2.3.1

- openSUSE Leap 15.0 (x86_64):

pdns-4.1.2-lp150.3.13.1
pdns-backend-geoip-4.1.2-lp150.3.13.1
pdns-backend-geoip-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-godbc-4.1.2-lp150.3.13.1
pdns-backend-godbc-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-ldap-4.1.2-lp150.3.13.1
pdns-backend-ldap-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-lua-4.1.2-lp150.3.13.1
pdns-backend-lua-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-mydns-4.1.2-lp150.3.13.1
pdns-backend-mydns-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-mysql-4.1.2-lp150.3.13.1
pdns-backend-mysql-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-postgresql-4.1.2-lp150.3.13.1
pdns-backend-postgresql-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-remote-4.1.2-lp150.3.13.1
pdns-backend-remote-debuginfo-4.1.2-lp150.3.13.1
pdns-backend-sqlite3-4.1.2-lp150.3.13.1
pdns-backend-sqlite3-debuginfo-4.1.2-lp150.3.13.1
pdns-debuginfo-4.1.2-lp150.3.13.1
pdns-debugsource-4.1.2-lp150.3.13.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

pdns-4.1.2-bp150.2.9.1
pdns-backend-geoip-4.1.2-bp150.2.9.1
pdns-backend-geoip-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-godbc-4.1.2-bp150.2.9.1
pdns-backend-godbc-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-ldap-4.1.2-bp150.2.9.1
pdns-backend-ldap-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-lua-4.1.2-bp150.2.9.1
pdns-backend-lua-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-mydns-4.1.2-bp150.2.9.1
pdns-backend-mydns-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-mysql-4.1.2-bp150.2.9.1
pdns-backend-mysql-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-postgresql-4.1.2-bp150.2.9.1
pdns-backend-postgresql-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-remote-4.1.2-bp150.2.9.1
pdns-backend-remote-debuginfo-4.1.2-bp150.2.9.1
pdns-backend-sqlite3-4.1.2-bp150.2.9.1
pdns-backend-sqlite3-debuginfo-4.1.2-bp150.2.9.1
pdns-debuginfo-4.1.2-bp150.2.9.1
pdns-debugsource-4.1.2-bp150.2.9.1


References:

https://www.suse.com/security/cve/CVE-2019-10162.html
https://www.suse.com/security/cve/CVE-2019-10163.html
https://www.suse.com/security/cve/CVE-2019-10203.html
https://bugzilla.suse.com/1138582
https://bugzilla.suse.com/1142810

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >