Mailinglist Archive: opensuse-security-announce (93 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1638-1: important: Security update for gstreamer-0_10-plugins-base
openSUSE Security Update: Security update for gstreamer-0_10-plugins-base
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1638-1
Rating: important
References: #1133375
Cross-References: CVE-2019-9928
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gstreamer-0_10-plugins-base fixes the following issues:

Security issue fixed:

- CVE-2019-9928: Fixed a heap-based overflow in the rtsp connection parser
(bsc#1133375).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1638=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

gstreamer-0_10-plugin-gnomevfs-0.10.36-18.3.1
gstreamer-0_10-plugin-gnomevfs-debuginfo-0.10.36-18.3.1
gstreamer-0_10-plugins-base-0.10.36-18.3.1
gstreamer-0_10-plugins-base-debuginfo-0.10.36-18.3.1
gstreamer-0_10-plugins-base-debugsource-0.10.36-18.3.1
gstreamer-0_10-plugins-base-devel-0.10.36-18.3.1
gstreamer-0_10-plugins-base-doc-0.10.36-18.3.1
libgstapp-0_10-0-0.10.36-18.3.1
libgstapp-0_10-0-debuginfo-0.10.36-18.3.1
libgstinterfaces-0_10-0-0.10.36-18.3.1
libgstinterfaces-0_10-0-debuginfo-0.10.36-18.3.1
typelib-1_0-GstApp-0_10-0.10.36-18.3.1
typelib-1_0-GstInterfaces-0_10-0.10.36-18.3.1

- openSUSE Leap 42.3 (noarch):

gstreamer-0_10-plugins-base-lang-0.10.36-18.3.1

- openSUSE Leap 42.3 (x86_64):

gstreamer-0_10-plugins-base-32bit-0.10.36-18.3.1
gstreamer-0_10-plugins-base-debuginfo-32bit-0.10.36-18.3.1
libgstapp-0_10-0-32bit-0.10.36-18.3.1
libgstapp-0_10-0-debuginfo-32bit-0.10.36-18.3.1
libgstinterfaces-0_10-0-32bit-0.10.36-18.3.1
libgstinterfaces-0_10-0-debuginfo-32bit-0.10.36-18.3.1


References:

https://www.suse.com/security/cve/CVE-2019-9928.html
https://bugzilla.suse.com/1133375

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages