Mailinglist Archive: opensuse-security-announce (93 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1505-1: important: Security update for libvirt
openSUSE Security Update: Security update for libvirt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1505-1
Rating: important
References: #1111331 #1135273
Cross-References: CVE-2018-12126 CVE-2018-12127 CVE-2018-12130
CVE-2019-11091
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for libvirt fixes the following issues:

Four new speculative execution information leak issues have been
identified in Intel CPUs. (bsc#1111331)

- CVE-2018-12126: Microarchitectural Store Buffer Data Sampling (MSBDS)
- CVE-2018-12127: Microarchitectural Fill Buffer Data Sampling (MFBDS)
- CVE-2018-12130: Microarchitectural Load Port Data Sampling (MLPDS)
- CVE-2019-11091: Microarchitectural Data Sampling Uncacheable Memory
(MDSUM)

These updates contain the libvirt adjustments, that pass through the new
'md-clear' CPU flag (bsc#1135273).

For more information on this set of vulnerabilities, check out
https://www.suse.com/support/kb/doc/?id=7023736

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1505=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libvirt-4.0.0-lp150.7.14.1
libvirt-admin-4.0.0-lp150.7.14.1
libvirt-admin-debuginfo-4.0.0-lp150.7.14.1
libvirt-client-4.0.0-lp150.7.14.1
libvirt-client-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-4.0.0-lp150.7.14.1
libvirt-daemon-config-network-4.0.0-lp150.7.14.1
libvirt-daemon-config-nwfilter-4.0.0-lp150.7.14.1
libvirt-daemon-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-interface-4.0.0-lp150.7.14.1
libvirt-daemon-driver-interface-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-lxc-4.0.0-lp150.7.14.1
libvirt-daemon-driver-lxc-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-network-4.0.0-lp150.7.14.1
libvirt-daemon-driver-network-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-nodedev-4.0.0-lp150.7.14.1
libvirt-daemon-driver-nodedev-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-nwfilter-4.0.0-lp150.7.14.1
libvirt-daemon-driver-nwfilter-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-qemu-4.0.0-lp150.7.14.1
libvirt-daemon-driver-qemu-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-secret-4.0.0-lp150.7.14.1
libvirt-daemon-driver-secret-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-core-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-core-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-disk-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-disk-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-iscsi-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-iscsi-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-logical-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-logical-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-mpath-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-mpath-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-scsi-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-scsi-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-uml-4.0.0-lp150.7.14.1
libvirt-daemon-driver-uml-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-vbox-4.0.0-lp150.7.14.1
libvirt-daemon-driver-vbox-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-hooks-4.0.0-lp150.7.14.1
libvirt-daemon-lxc-4.0.0-lp150.7.14.1
libvirt-daemon-qemu-4.0.0-lp150.7.14.1
libvirt-daemon-uml-4.0.0-lp150.7.14.1
libvirt-daemon-vbox-4.0.0-lp150.7.14.1
libvirt-debugsource-4.0.0-lp150.7.14.1
libvirt-devel-4.0.0-lp150.7.14.1
libvirt-doc-4.0.0-lp150.7.14.1
libvirt-libs-4.0.0-lp150.7.14.1
libvirt-libs-debuginfo-4.0.0-lp150.7.14.1
libvirt-lock-sanlock-4.0.0-lp150.7.14.1
libvirt-lock-sanlock-debuginfo-4.0.0-lp150.7.14.1
libvirt-nss-4.0.0-lp150.7.14.1
libvirt-nss-debuginfo-4.0.0-lp150.7.14.1
wireshark-plugin-libvirt-4.0.0-lp150.7.14.1
wireshark-plugin-libvirt-debuginfo-4.0.0-lp150.7.14.1

- openSUSE Leap 15.0 (x86_64):

libvirt-client-32bit-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-libxl-4.0.0-lp150.7.14.1
libvirt-daemon-driver-libxl-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-rbd-4.0.0-lp150.7.14.1
libvirt-daemon-driver-storage-rbd-debuginfo-4.0.0-lp150.7.14.1
libvirt-daemon-xen-4.0.0-lp150.7.14.1
libvirt-devel-32bit-4.0.0-lp150.7.14.1


References:

https://www.suse.com/security/cve/CVE-2018-12126.html
https://www.suse.com/security/cve/CVE-2018-12127.html
https://www.suse.com/security/cve/CVE-2018-12130.html
https://www.suse.com/security/cve/CVE-2019-11091.html
https://bugzilla.suse.com/1111331
https://bugzilla.suse.com/1135273

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages