Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1477-1: important: Security update for gnutls
openSUSE Security Update: Security update for gnutls
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1477-1
Rating: important
References: #1118087 #1134856
Cross-References: CVE-2018-16868
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for gnutls fixes the following issues:

Security issue fixed:

- CVE-2018-16868: Fixed Bleichenbacher-like side channel leakage in PKCS#1
v1.5 verification (bsc#1118087).

Non-security issue fixed:

- Explicitly require libnettle 3.4.1 to prevent missing symbol errors
(bsc#1134856).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1477=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1477=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

gnutls-3.6.7-lp151.2.3.1
gnutls-debuginfo-3.6.7-lp151.2.3.1
gnutls-debugsource-3.6.7-lp151.2.3.1
gnutls-guile-3.6.7-lp151.2.3.1
gnutls-guile-debuginfo-3.6.7-lp151.2.3.1
libgnutls-dane-devel-3.6.7-lp151.2.3.1
libgnutls-dane0-3.6.7-lp151.2.3.1
libgnutls-dane0-debuginfo-3.6.7-lp151.2.3.1
libgnutls-devel-3.6.7-lp151.2.3.1
libgnutls30-3.6.7-lp151.2.3.1
libgnutls30-debuginfo-3.6.7-lp151.2.3.1
libgnutlsxx-devel-3.6.7-lp151.2.3.1
libgnutlsxx28-3.6.7-lp151.2.3.1
libgnutlsxx28-debuginfo-3.6.7-lp151.2.3.1

- openSUSE Leap 15.1 (x86_64):

libgnutls-devel-32bit-3.6.7-lp151.2.3.1
libgnutls30-32bit-3.6.7-lp151.2.3.1
libgnutls30-32bit-debuginfo-3.6.7-lp151.2.3.1

- openSUSE Leap 15.0 (i586 x86_64):

gnutls-3.6.7-lp150.12.1
gnutls-debuginfo-3.6.7-lp150.12.1
gnutls-debugsource-3.6.7-lp150.12.1
gnutls-guile-3.6.7-lp150.12.1
gnutls-guile-debuginfo-3.6.7-lp150.12.1
libgnutls-dane-devel-3.6.7-lp150.12.1
libgnutls-dane0-3.6.7-lp150.12.1
libgnutls-dane0-debuginfo-3.6.7-lp150.12.1
libgnutls-devel-3.6.7-lp150.12.1
libgnutls30-3.6.7-lp150.12.1
libgnutls30-debuginfo-3.6.7-lp150.12.1
libgnutlsxx-devel-3.6.7-lp150.12.1
libgnutlsxx28-3.6.7-lp150.12.1
libgnutlsxx28-debuginfo-3.6.7-lp150.12.1

- openSUSE Leap 15.0 (x86_64):

libgnutls-devel-32bit-3.6.7-lp150.12.1
libgnutls30-32bit-3.6.7-lp150.12.1
libgnutls30-32bit-debuginfo-3.6.7-lp150.12.1


References:

https://www.suse.com/security/cve/CVE-2018-16868.html
https://bugzilla.suse.com/1118087
https://bugzilla.suse.com/1134856

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages