Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1344-1: moderate: Security update for rubygem-actionpack-5_1
openSUSE Security Update: Security update for rubygem-actionpack-5_1
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1344-1
Rating: moderate
References: #1129271 #1129272
Cross-References: CVE-2019-5418 CVE-2019-5419
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for rubygem-actionpack-5_1 fixes the following issues:

Security issues fixed:

- CVE-2019-5418: Fixed a file content disclosure vulnerability in Action
View which could be exploited via specially crafted accept headers in
combination with calls to render file (bsc#1129272).
- CVE-2019-5419: Fixed a resource exhaustion issue in Action View which
could make the server unable to process requests (bsc#1129271).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1344=1



Package List:

- openSUSE Leap 15.0 (x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-lp150.2.3.1
ruby2.5-rubygem-actionpack-doc-5_1-5.1.4-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2019-5418.html
https://www.suse.com/security/cve/CVE-2019-5419.html
https://bugzilla.suse.com/1129271
https://bugzilla.suse.com/1129272

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages