Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1327-1: moderate: Security update for java-11-openjdk
openSUSE Security Update: Security update for java-11-openjdk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1327-1
Rating: moderate
References: #1132728 #1132732
Cross-References: CVE-2019-2602 CVE-2019-2684
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for java-11-openjdk to version 11.0.3+7 fixes the following
issues:

Security issues fixed:

- CVE-2019-2602: Fixed excessive use of CPU time in the BigDecimal
implementation (bsc#1132728).
- CVE-2019-2684: Fixed a flaw in the RMI registry implementation which
could lead to selection of an incorrect skeleton class (bsc#1132732).

Non-security issues fixed:

- Multiple bug fixes and improvements.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1327=1



Package List:

- openSUSE Leap 15.0 (noarch):

java-11-openjdk-javadoc-11.0.3.0-lp150.2.16.1

- openSUSE Leap 15.0 (x86_64):

java-11-openjdk-11.0.3.0-lp150.2.16.1
java-11-openjdk-accessibility-11.0.3.0-lp150.2.16.1
java-11-openjdk-accessibility-debuginfo-11.0.3.0-lp150.2.16.1
java-11-openjdk-debuginfo-11.0.3.0-lp150.2.16.1
java-11-openjdk-debugsource-11.0.3.0-lp150.2.16.1
java-11-openjdk-demo-11.0.3.0-lp150.2.16.1
java-11-openjdk-devel-11.0.3.0-lp150.2.16.1
java-11-openjdk-headless-11.0.3.0-lp150.2.16.1
java-11-openjdk-jmods-11.0.3.0-lp150.2.16.1
java-11-openjdk-src-11.0.3.0-lp150.2.16.1


References:

https://www.suse.com/security/cve/CVE-2019-2602.html
https://www.suse.com/security/cve/CVE-2019-2684.html
https://bugzilla.suse.com/1132728
https://bugzilla.suse.com/1132732

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages