Mailinglist Archive: opensuse-security-announce (108 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1284-1: moderate: Security update for ceph
openSUSE Security Update: Security update for ceph
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1284-1
Rating: moderate
References: #1084645 #1086613 #1096748 #1099162 #1101262
#1111177 #1114567 #1114710
Cross-References: CVE-2018-10861 CVE-2018-1128 CVE-2018-1129
CVE-2018-14662 CVE-2018-16846
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves 5 vulnerabilities and has three fixes
is now available.

Description:

This update for ceph version 13.2.4 fixes the following issues:

Security issues fixed:

- CVE-2018-14662: Fixed an issue with LUKS 'config-key' safety
(bsc#1111177)
- CVE-2018-10861: Fixed an authorization bypass on OSD pool ops in
ceph-mon (bsc#1099162)
- CVE-2018-1128: Fixed signature check bypass in cephx (bsc#1096748)
- CVE-2018-1129: Fixed replay attack in cephx protocol (bsc#1096748)
- CVE-2018-16846: Enforced bounds on max-keys/max-uploads/max-parts in rgw
(bsc#1114710)

Non-security issues fixed:

- ceph-volume Python 3 fixes (bsc#1114567)
- Fixed python3 module loading (bsc#1086613)
- Fixed an issue where ceph build fails (bsc#1084645)
- ceph's SPDK builds with march=native (bsc#1101262)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1284=1



Package List:

- openSUSE Leap 15.0 (x86_64):

ceph-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-base-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-base-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-common-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-common-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-debugsource-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-fuse-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-fuse-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mds-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mds-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mgr-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mgr-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mon-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-mon-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-osd-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-osd-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-radosgw-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-radosgw-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-resource-agents-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-test-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-test-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
ceph-test-debugsource-13.2.4.125+gad802694f5-lp150.2.3.1
libcephfs-devel-13.2.4.125+gad802694f5-lp150.2.3.1
libcephfs2-13.2.4.125+gad802694f5-lp150.2.3.1
libcephfs2-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
librados-devel-13.2.4.125+gad802694f5-lp150.2.3.1
librados-devel-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
librados2-13.2.4.125+gad802694f5-lp150.2.3.1
librados2-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
libradosstriper-devel-13.2.4.125+gad802694f5-lp150.2.3.1
libradosstriper1-13.2.4.125+gad802694f5-lp150.2.3.1
libradosstriper1-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
librbd-devel-13.2.4.125+gad802694f5-lp150.2.3.1
librbd1-13.2.4.125+gad802694f5-lp150.2.3.1
librbd1-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
librgw-devel-13.2.4.125+gad802694f5-lp150.2.3.1
librgw2-13.2.4.125+gad802694f5-lp150.2.3.1
librgw2-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
python3-cephfs-13.2.4.125+gad802694f5-lp150.2.3.1
python3-cephfs-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rados-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rados-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rbd-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rbd-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rgw-13.2.4.125+gad802694f5-lp150.2.3.1
python3-rgw-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
rados-objclass-devel-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-fuse-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-fuse-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-mirror-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-mirror-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-nbd-13.2.4.125+gad802694f5-lp150.2.3.1
rbd-nbd-debuginfo-13.2.4.125+gad802694f5-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10861.html
https://www.suse.com/security/cve/CVE-2018-1128.html
https://www.suse.com/security/cve/CVE-2018-1129.html
https://www.suse.com/security/cve/CVE-2018-14662.html
https://www.suse.com/security/cve/CVE-2018-16846.html
https://bugzilla.suse.com/1084645
https://bugzilla.suse.com/1086613
https://bugzilla.suse.com/1096748
https://bugzilla.suse.com/1099162
https://bugzilla.suse.com/1101262
https://bugzilla.suse.com/1111177
https://bugzilla.suse.com/1114567
https://bugzilla.suse.com/1114710

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages