Mailinglist Archive: opensuse-security-announce (108 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1220-1: important: Security update for dovecot22
openSUSE Security Update: Security update for dovecot22
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1220-1
Rating: important
References: #1111789 #1123022 #1130116
Cross-References: CVE-2019-3814 CVE-2019-7524
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for dovecot22 fixes the following issues:

Security issues fixed:

- CVE-2019-7524: Fixed an improper file handling which could result in
stack overflow allowing local root escalation (bsc#1130116).
- CVE-2019-3814: Fixed a vulnerability related to SSL client certificate
authentication (bsc#1123022).

Other issue fixed:
- Fixed handling of command continuation (bsc#1111789).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1220=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

dovecot22-2.2.31-2.12.1
dovecot22-backend-mysql-2.2.31-2.12.1
dovecot22-backend-mysql-debuginfo-2.2.31-2.12.1
dovecot22-backend-pgsql-2.2.31-2.12.1
dovecot22-backend-pgsql-debuginfo-2.2.31-2.12.1
dovecot22-backend-sqlite-2.2.31-2.12.1
dovecot22-backend-sqlite-debuginfo-2.2.31-2.12.1
dovecot22-debuginfo-2.2.31-2.12.1
dovecot22-debugsource-2.2.31-2.12.1
dovecot22-devel-2.2.31-2.12.1
dovecot22-fts-2.2.31-2.12.1
dovecot22-fts-debuginfo-2.2.31-2.12.1
dovecot22-fts-lucene-2.2.31-2.12.1
dovecot22-fts-lucene-debuginfo-2.2.31-2.12.1
dovecot22-fts-solr-2.2.31-2.12.1
dovecot22-fts-solr-debuginfo-2.2.31-2.12.1
dovecot22-fts-squat-2.2.31-2.12.1
dovecot22-fts-squat-debuginfo-2.2.31-2.12.1


References:

https://www.suse.com/security/cve/CVE-2019-3814.html
https://www.suse.com/security/cve/CVE-2019-7524.html
https://bugzilla.suse.com/1111789
https://bugzilla.suse.com/1123022
https://bugzilla.suse.com/1130116

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages