Mailinglist Archive: opensuse-security-announce (108 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1120-1: moderate: Security update for libgxps
openSUSE Security Update: Security update for libgxps
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1120-1
Rating: moderate
References: #1092125
Cross-References: CVE-2018-10733
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for libgxps fixes the following issues:

- CVE-2018-10733: Fixed a heap-based buffer over-read issue in
ft_font_face_hash (bsc#1092125).


This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1120=1



Package List:

- openSUSE Leap 15.0 (x86_64):

libgxps-debuginfo-0.3.0-lp150.3.3.2
libgxps-debugsource-0.3.0-lp150.3.3.2
libgxps-devel-0.3.0-lp150.3.3.2
libgxps-tools-0.3.0-lp150.3.3.2
libgxps-tools-debuginfo-0.3.0-lp150.3.3.2
libgxps2-0.3.0-lp150.3.3.2
libgxps2-debuginfo-0.3.0-lp150.3.3.2
typelib-1_0-GXPS-0_1-0.3.0-lp150.3.3.2


References:

https://www.suse.com/security/cve/CVE-2018-10733.html
https://bugzilla.suse.com/1092125

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages