Mailinglist Archive: opensuse-security-announce (51 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:0089-1: important: Security update for nodejs8
openSUSE Security Update: Security update for nodejs8
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0089-1
Rating: important
References: #1117626 #1117627 #1117629 #1117630
Cross-References: CVE-2018-12116 CVE-2018-12121 CVE-2018-12122
CVE-2018-12123
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for nodejs8 to version 8.15.0 fixes the following issues:

Security issues fixed:

- CVE-2018-12121: Fixed a Denial of Service with large HTTP headers
(bsc#1117626)
- CVE-2018-12122: Fixed the 'Slowloris' HTTP Denial of Service
(bsc#1117627)
- CVE-2018-12116: Fixed HTTP request splitting (bsc#1117630)
- CVE-2018-12123: Fixed hostname spoofing in URL parser for javascript
protocol (bsc#1117629)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-89=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

nodejs8-8.15.0-lp150.2.9.1
nodejs8-debuginfo-8.15.0-lp150.2.9.1
nodejs8-debugsource-8.15.0-lp150.2.9.1
nodejs8-devel-8.15.0-lp150.2.9.1
npm8-8.15.0-lp150.2.9.1

- openSUSE Leap 15.0 (noarch):

nodejs8-docs-8.15.0-lp150.2.9.1


References:

https://www.suse.com/security/cve/CVE-2018-12116.html
https://www.suse.com/security/cve/CVE-2018-12121.html
https://www.suse.com/security/cve/CVE-2018-12122.html
https://www.suse.com/security/cve/CVE-2018-12123.html
https://bugzilla.suse.com/1117626
https://bugzilla.suse.com/1117627
https://bugzilla.suse.com/1117629
https://bugzilla.suse.com/1117630

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages