Mailinglist Archive: opensuse-security-announce (57 mails)

< Previous Next >
[security-announce] openSUSE-SU-2018:1854-1: important: Security update for rubygem-sprockets
openSUSE Security Update: Security update for rubygem-sprockets
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1854-1
Rating: important
References: #1098369
Cross-References: CVE-2018-3760
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for rubygem-sprockets fixes the following issues:

The following security vulnerability was addressed:

- CVE-2018-3760: Fixed a directory traversal issue in
sprockets/server.rb:forbidden_request?(), which allowed remote attackers
to read arbitrary files via specially crafted requests. (boo#1098369)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-686=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

ruby2.1-rubygem-sprockets-3.3.5-5.3.1
ruby2.1-rubygem-sprockets-doc-3.3.5-5.3.1
ruby2.2-rubygem-sprockets-3.3.5-5.3.1
ruby2.2-rubygem-sprockets-doc-3.3.5-5.3.1
ruby2.3-rubygem-sprockets-3.3.5-5.3.1
ruby2.3-rubygem-sprockets-doc-3.3.5-5.3.1
ruby2.4-rubygem-sprockets-3.3.5-5.3.1
ruby2.4-rubygem-sprockets-doc-3.3.5-5.3.1


References:

https://www.suse.com/security/cve/CVE-2018-3760.html
https://bugzilla.suse.com/1098369

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages