Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] SUSE-SU-2018:0451-1: important: Security update for glibc
SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:0451-1
Rating: important
References: #1037930 #1051791 #1073990 #1074293 #1079036

Cross-References: CVE-2017-12132 CVE-2017-8804 CVE-2018-1000001
CVE-2018-6485 CVE-2018-6551
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Software Development Kit 12-SP2
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP2
SUSE Linux Enterprise Desktop 12-SP3
SUSE Linux Enterprise Desktop 12-SP2
SUSE CaaS Platform ALL
OpenStack Cloud Magnum Orchestration 7
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:



This update for glibc fixes the following issues:

Security issues fixed:

- CVE-2017-8804: Fix memory leak after deserialization failure in
xdr_bytes, xdr_string (bsc#1037930)
- CVE-2017-12132: Reduce EDNS payload size to 1200 bytes (bsc#1051791)
- CVE-2018-6485,CVE-2018-6551: Fix integer overflows in internal memalign
and malloc functions (bsc#1079036)
- CVE-2018-1000001: Avoid underflow of malloced area (bsc#1074293)

Non security bugs fixed:

- Release read lock after resetting timeout (bsc#1073990)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-314=1

- SUSE Linux Enterprise Software Development Kit 12-SP2:

zypper in -t patch SUSE-SLE-SDK-12-SP2-2018-314=1

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

zypper in -t patch SUSE-SLE-RPI-12-SP2-2018-314=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-314=1

- SUSE Linux Enterprise Server 12-SP2:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-314=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-314=1

- SUSE Linux Enterprise Desktop 12-SP2:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2018-314=1

- SUSE CaaS Platform ALL:

zypper in -t patch SUSE-CAASP-ALL-2018-314=1

- OpenStack Cloud Magnum Orchestration 7:

zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-314=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-static-2.22-62.6.2

- SUSE Linux Enterprise Software Development Kit 12-SP3 (noarch):

glibc-info-2.22-62.6.2

- SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le
s390x x86_64):

glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-static-2.22-62.6.2

- SUSE Linux Enterprise Software Development Kit 12-SP2 (noarch):

glibc-info-2.22-62.6.2

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):

glibc-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-2.22-62.6.2
glibc-devel-debuginfo-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2
glibc-profile-2.22-62.6.2
nscd-2.22-62.6.2
nscd-debuginfo-2.22-62.6.2

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (noarch):

glibc-html-2.22-62.6.2
glibc-i18ndata-2.22-62.6.2
glibc-info-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

glibc-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-2.22-62.6.2
glibc-devel-debuginfo-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2
glibc-profile-2.22-62.6.2
nscd-2.22-62.6.2
nscd-debuginfo-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP3 (s390x x86_64):

glibc-32bit-2.22-62.6.2
glibc-debuginfo-32bit-2.22-62.6.2
glibc-devel-32bit-2.22-62.6.2
glibc-devel-debuginfo-32bit-2.22-62.6.2
glibc-locale-32bit-2.22-62.6.2
glibc-locale-debuginfo-32bit-2.22-62.6.2
glibc-profile-32bit-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP3 (noarch):

glibc-html-2.22-62.6.2
glibc-i18ndata-2.22-62.6.2
glibc-info-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):

glibc-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-2.22-62.6.2
glibc-devel-debuginfo-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2
glibc-profile-2.22-62.6.2
nscd-2.22-62.6.2
nscd-debuginfo-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP2 (s390x x86_64):

glibc-32bit-2.22-62.6.2
glibc-debuginfo-32bit-2.22-62.6.2
glibc-devel-32bit-2.22-62.6.2
glibc-devel-debuginfo-32bit-2.22-62.6.2
glibc-locale-32bit-2.22-62.6.2
glibc-locale-debuginfo-32bit-2.22-62.6.2
glibc-profile-32bit-2.22-62.6.2

- SUSE Linux Enterprise Server 12-SP2 (noarch):

glibc-html-2.22-62.6.2
glibc-i18ndata-2.22-62.6.2
glibc-info-2.22-62.6.2

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

glibc-2.22-62.6.2
glibc-32bit-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debuginfo-32bit-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-2.22-62.6.2
glibc-devel-32bit-2.22-62.6.2
glibc-devel-debuginfo-2.22-62.6.2
glibc-devel-debuginfo-32bit-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-32bit-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2
glibc-locale-debuginfo-32bit-2.22-62.6.2
nscd-2.22-62.6.2
nscd-debuginfo-2.22-62.6.2

- SUSE Linux Enterprise Desktop 12-SP3 (noarch):

glibc-i18ndata-2.22-62.6.2

- SUSE Linux Enterprise Desktop 12-SP2 (noarch):

glibc-i18ndata-2.22-62.6.2

- SUSE Linux Enterprise Desktop 12-SP2 (x86_64):

glibc-2.22-62.6.2
glibc-32bit-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debuginfo-32bit-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-devel-2.22-62.6.2
glibc-devel-32bit-2.22-62.6.2
glibc-devel-debuginfo-2.22-62.6.2
glibc-devel-debuginfo-32bit-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-32bit-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2
glibc-locale-debuginfo-32bit-2.22-62.6.2
nscd-2.22-62.6.2
nscd-debuginfo-2.22-62.6.2

- SUSE CaaS Platform ALL (x86_64):

glibc-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2

- OpenStack Cloud Magnum Orchestration 7 (x86_64):

glibc-2.22-62.6.2
glibc-debuginfo-2.22-62.6.2
glibc-debugsource-2.22-62.6.2
glibc-locale-2.22-62.6.2
glibc-locale-debuginfo-2.22-62.6.2


References:

https://www.suse.com/security/cve/CVE-2017-12132.html
https://www.suse.com/security/cve/CVE-2017-8804.html
https://www.suse.com/security/cve/CVE-2018-1000001.html
https://www.suse.com/security/cve/CVE-2018-6485.html
https://www.suse.com/security/cve/CVE-2018-6551.html
https://bugzilla.suse.com/1037930
https://bugzilla.suse.com/1051791
https://bugzilla.suse.com/1073990
https://bugzilla.suse.com/1074293
https://bugzilla.suse.com/1079036

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages