Mailinglist Archive: opensuse-security-announce (87 mails)

< Previous Next >
[security-announce] openSUSE-SU-2017:2884-1: important: Security update for wget
openSUSE Security Update: Security update for wget
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2884-1
Rating: important
References: #1064715 #1064716
Cross-References: CVE-2017-13089 CVE-2017-13090
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for wget fixes the following security issues:

- CVE-2017-13089,CVE-2017-13090: Missing checks for negative
remaining_chunk_size in skip_short_body and fd_read_body could cause
stack buffer overflows, which could have been exploited by malicious
servers. (bsc#1064715,bsc#1064716)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1210=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1210=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

wget-1.14-12.1
wget-debuginfo-1.14-12.1
wget-debugsource-1.14-12.1

- openSUSE Leap 42.2 (i586 x86_64):

wget-1.14-8.6.1
wget-debuginfo-1.14-8.6.1
wget-debugsource-1.14-8.6.1


References:

https://www.suse.com/security/cve/CVE-2017-13089.html
https://www.suse.com/security/cve/CVE-2017-13090.html
https://bugzilla.suse.com/1064715
https://bugzilla.suse.com/1064716

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages