Mailinglist Archive: opensuse-security-announce (87 mails)

< Previous Next >
[security-announce] SUSE-SU-2017:2752-1: important: Security update for wpa_supplicant
SUSE Security Update: Security update for wpa_supplicant
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:2752-1
Rating: important
References: #1056061
Cross-References: CVE-2017-13078 CVE-2017-13079 CVE-2017-13080
CVE-2017-13081 CVE-2017-13087 CVE-2017-13088

Affected Products:
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Server 11-SP3-LTSS
SUSE Linux Enterprise Point of Sale 11-SP3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for wpa_supplicant fixes the following issues:

- Several vulnerabilities in standard conforming implementations of the
WPA2 protocol have been discovered and published under the code name
KRACK. This update remedies those issues in a backwards compatible
manner, i.e. the updated wpa_supplicant can interface properly with both
vulnerable and patched implementations of WPA2, but an attacker won't be
able to exploit the KRACK weaknesses in those connections anymore even
if the other party is still vulnerable. [bsc#1056061, CVE-2017-13078,
CVE-2017-13079, CVE-2017-13080, CVE-2017-13081, CVE-2017-13087,
CVE-2017-13088]


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-wpa_supplicant-13318=1

- SUSE Linux Enterprise Server 11-SP3-LTSS:

zypper in -t patch slessp3-wpa_supplicant-13318=1

- SUSE Linux Enterprise Point of Sale 11-SP3:

zypper in -t patch sleposp3-wpa_supplicant-13318=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

wpa_supplicant-0.7.1-6.18.3.1

- SUSE Linux Enterprise Server 11-SP3-LTSS (i586 s390x x86_64):

wpa_supplicant-0.7.1-6.18.3.1

- SUSE Linux Enterprise Point of Sale 11-SP3 (i586):

wpa_supplicant-0.7.1-6.18.3.1


References:

https://www.suse.com/security/cve/CVE-2017-13078.html
https://www.suse.com/security/cve/CVE-2017-13079.html
https://www.suse.com/security/cve/CVE-2017-13080.html
https://www.suse.com/security/cve/CVE-2017-13081.html
https://www.suse.com/security/cve/CVE-2017-13087.html
https://www.suse.com/security/cve/CVE-2017-13088.html
https://bugzilla.suse.com/1056061

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages