Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] openSUSE-SU-2017:1572-1: important: Security update for mercurial
openSUSE Security Update: Security update for mercurial
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1572-1
Rating: important
References: #1043063 #1043502
Cross-References: CVE-2017-9462
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for mercurial fixes the following issues:

- CVE-2017-9462: Fix the arbitrary code exec by remote users via "hg serve
--stdio" (boo#1043063)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-689=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

mercurial-3.8.3-2.5.1
mercurial-debuginfo-3.8.3-2.5.1
mercurial-debugsource-3.8.3-2.5.1

- openSUSE Leap 42.2 (noarch):

mercurial-lang-3.8.3-2.5.1


References:

https://www.suse.com/security/cve/CVE-2017-9462.html
https://bugzilla.suse.com/1043063
https://bugzilla.suse.com/1043502

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages