Mailinglist Archive: opensuse-security-announce (47 mails)

< Previous Next >
[security-announce] openSUSE-SU-2016:2768-1: important: Security update for curl
openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2768-1
Rating: important
References: #1005633 #1005634 #1005635 #1005637 #1005638
#1005640 #1005642 #1005643 #1005645 #1005646
#998760
Cross-References: CVE-2016-7167 CVE-2016-8615 CVE-2016-8616
CVE-2016-8617 CVE-2016-8618 CVE-2016-8619
CVE-2016-8620 CVE-2016-8621 CVE-2016-8622
CVE-2016-8623 CVE-2016-8624
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:

This update for curl fixes the following security issues:

- CVE-2016-8624: invalid URL parsing with '#' (bsc#1005646)
- CVE-2016-8623: Use-after-free via shared cookies (bsc#1005645)
- CVE-2016-8622: URL unescape heap overflow via integer truncation
(bsc#1005643)
- CVE-2016-8621: curl_getdate read out of bounds (bsc#1005642)
- CVE-2016-8620: glob parser write/read out of bounds (bsc#1005640)
- CVE-2016-8619: double-free in krb5 code (bsc#1005638)
- CVE-2016-8618: double-free in curl_maprintf (bsc#1005637)
- CVE-2016-8617: OOB write via unchecked multiplication (bsc#1005635)
- CVE-2016-8616: case insensitive password comparison (bsc#1005634)
- CVE-2016-8615: cookie injection for other servers (bsc#1005633)
- CVE-2016-7167: escape and unescape integer overflows (bsc#998760)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1280=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

curl-7.37.0-16.1
curl-debuginfo-7.37.0-16.1
curl-debugsource-7.37.0-16.1
libcurl-devel-7.37.0-16.1
libcurl4-7.37.0-16.1
libcurl4-debuginfo-7.37.0-16.1

- openSUSE Leap 42.1 (x86_64):

libcurl-devel-32bit-7.37.0-16.1
libcurl4-32bit-7.37.0-16.1
libcurl4-debuginfo-32bit-7.37.0-16.1


References:

https://www.suse.com/security/cve/CVE-2016-7167.html
https://www.suse.com/security/cve/CVE-2016-8615.html
https://www.suse.com/security/cve/CVE-2016-8616.html
https://www.suse.com/security/cve/CVE-2016-8617.html
https://www.suse.com/security/cve/CVE-2016-8618.html
https://www.suse.com/security/cve/CVE-2016-8619.html
https://www.suse.com/security/cve/CVE-2016-8620.html
https://www.suse.com/security/cve/CVE-2016-8621.html
https://www.suse.com/security/cve/CVE-2016-8622.html
https://www.suse.com/security/cve/CVE-2016-8623.html
https://www.suse.com/security/cve/CVE-2016-8624.html
https://bugzilla.suse.com/1005633
https://bugzilla.suse.com/1005634
https://bugzilla.suse.com/1005635
https://bugzilla.suse.com/1005637
https://bugzilla.suse.com/1005638
https://bugzilla.suse.com/1005640
https://bugzilla.suse.com/1005642
https://bugzilla.suse.com/1005643
https://bugzilla.suse.com/1005645
https://bugzilla.suse.com/1005646
https://bugzilla.suse.com/998760

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages