Mailinglist Archive: opensuse-security-announce (62 mails)

< Previous Next >
[security-announce] SUSE-SU-2016:1710-1: important: Security update for the Linux Kernel
SUSE Security Update: Security update for the Linux Kernel
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:1710-1
Rating: important
References: #986362
Cross-References: CVE-2016-4998
Affected Products:
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Module for Public Cloud 12
SUSE Linux Enterprise Live Patching 12
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


The SUSE Linux Enterprise 12 GA kernel was updated to receive one critical
security fix.

Security issue fixed:
- CVE-2016-4997: A buffer overflow in 32bit compat_setsockopt iptables
handling could lead to a local privilege escalation. (bsc#986362)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 12:

zypper in -t patch SUSE-SLE-WE-12-2016-1013=1

- SUSE Linux Enterprise Software Development Kit 12:

zypper in -t patch SUSE-SLE-SDK-12-2016-1013=1

- SUSE Linux Enterprise Server 12:

zypper in -t patch SUSE-SLE-SERVER-12-2016-1013=1

- SUSE Linux Enterprise Module for Public Cloud 12:

zypper in -t patch SUSE-SLE-Module-Public-Cloud-12-2016-1013=1

- SUSE Linux Enterprise Live Patching 12:

zypper in -t patch SUSE-SLE-Live-Patching-12-2016-1013=1

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2016-1013=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Workstation Extension 12 (x86_64):

kernel-default-debuginfo-3.12.60-52.54.2
kernel-default-debugsource-3.12.60-52.54.2
kernel-default-extra-3.12.60-52.54.2
kernel-default-extra-debuginfo-3.12.60-52.54.2

- SUSE Linux Enterprise Software Development Kit 12 (ppc64le s390x x86_64):

kernel-obs-build-3.12.60-52.54.3
kernel-obs-build-debugsource-3.12.60-52.54.3

- SUSE Linux Enterprise Software Development Kit 12 (noarch):

kernel-docs-3.12.60-52.54.3

- SUSE Linux Enterprise Server 12 (ppc64le s390x x86_64):

kernel-default-3.12.60-52.54.2
kernel-default-base-3.12.60-52.54.2
kernel-default-base-debuginfo-3.12.60-52.54.2
kernel-default-debuginfo-3.12.60-52.54.2
kernel-default-debugsource-3.12.60-52.54.2
kernel-default-devel-3.12.60-52.54.2
kernel-syms-3.12.60-52.54.1

- SUSE Linux Enterprise Server 12 (x86_64):

kernel-xen-3.12.60-52.54.2
kernel-xen-base-3.12.60-52.54.2
kernel-xen-base-debuginfo-3.12.60-52.54.2
kernel-xen-debuginfo-3.12.60-52.54.2
kernel-xen-debugsource-3.12.60-52.54.2
kernel-xen-devel-3.12.60-52.54.2

- SUSE Linux Enterprise Server 12 (noarch):

kernel-devel-3.12.60-52.54.1
kernel-macros-3.12.60-52.54.1
kernel-source-3.12.60-52.54.1

- SUSE Linux Enterprise Server 12 (s390x):

kernel-default-man-3.12.60-52.54.2

- SUSE Linux Enterprise Module for Public Cloud 12 (x86_64):

kernel-ec2-3.12.60-52.54.2
kernel-ec2-debuginfo-3.12.60-52.54.2
kernel-ec2-debugsource-3.12.60-52.54.2
kernel-ec2-devel-3.12.60-52.54.2
kernel-ec2-extra-3.12.60-52.54.2
kernel-ec2-extra-debuginfo-3.12.60-52.54.2

- SUSE Linux Enterprise Live Patching 12 (x86_64):

kgraft-patch-3_12_60-52_54-default-1-2.3
kgraft-patch-3_12_60-52_54-xen-1-2.3

- SUSE Linux Enterprise Desktop 12 (noarch):

kernel-devel-3.12.60-52.54.1
kernel-macros-3.12.60-52.54.1
kernel-source-3.12.60-52.54.1

- SUSE Linux Enterprise Desktop 12 (x86_64):

kernel-default-3.12.60-52.54.2
kernel-default-debuginfo-3.12.60-52.54.2
kernel-default-debugsource-3.12.60-52.54.2
kernel-default-devel-3.12.60-52.54.2
kernel-default-extra-3.12.60-52.54.2
kernel-default-extra-debuginfo-3.12.60-52.54.2
kernel-syms-3.12.60-52.54.1
kernel-xen-3.12.60-52.54.2
kernel-xen-debuginfo-3.12.60-52.54.2
kernel-xen-debugsource-3.12.60-52.54.2
kernel-xen-devel-3.12.60-52.54.2


References:

https://www.suse.com/security/cve/CVE-2016-4998.html
https://bugzilla.suse.com/986362

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages