Mailinglist Archive: opensuse-security-announce (58 mails)

< Previous Next >
[security-announce] SUSE-SU-2016:0391-1: important: Security update for rubygem-rails-html-sanitizer
SUSE Security Update: Security update for rubygem-rails-html-sanitizer
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:0391-1
Rating: important
References: #963326 #963327 #963328
Cross-References: CVE-2015-7578 CVE-2015-7579 CVE-2015-7580

Affected Products:
SUSE Enterprise Storage 2.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update for rubygem-rails-html-sanitizer fixes the following issues:

- CVE-2015-7579: XSS vulnerability in rails-html-sanitizer (bsc#963327)
- CVE-2015-7578: XSS vulnerability via attributes (bsc#963326)
- CVE-2015-7580: XSS via whitelist sanitizer (bsc#963328)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Enterprise Storage 2.1:

zypper in -t patch SUSE-Storage-2.1-2016-228=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Enterprise Storage 2.1 (x86_64):

ruby2.1-rubygem-rails-html-sanitizer-1.0.2-7.1


References:

https://www.suse.com/security/cve/CVE-2015-7578.html
https://www.suse.com/security/cve/CVE-2015-7579.html
https://www.suse.com/security/cve/CVE-2015-7580.html
https://bugzilla.suse.com/963326
https://bugzilla.suse.com/963327
https://bugzilla.suse.com/963328

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages