Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] openSUSE-SU-2015:2244-1: important: Security update to MariaDB 10.0.22
openSUSE Security Update: Security update to MariaDB 10.0.22
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2244-1
Rating: important
References: #937787
Cross-References: CVE-2015-4792 CVE-2015-4802 CVE-2015-4807
CVE-2015-4815 CVE-2015-4826 CVE-2015-4830
CVE-2015-4836 CVE-2015-4858 CVE-2015-4861
CVE-2015-4870 CVE-2015-4913
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:

MariaDB was updated to 10.0.22 to fix security issues and bugs.

The following vulnerabilities were fixed in the upstream release:

CVE-2015-4802, CVE-2015-4807, CVE-2015-4815, CVE-2015-4826,
CVE-2015-4830, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4870,
CVE-2015-4913, CVE-2015-4792

A list of upstream changes and release notes can be found here:

* https://kb.askmonty.org/en/mariadb-10022-release-notes/
* https://kb.askmonty.org/en/mariadb-10022-changelog/

The following build problems were fixed:

* bsc#937787: fix main.bootstrap test (change default charset to utf8 in
test result)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-884=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libmysqlclient-devel-10.0.22-2.18.1
libmysqlclient18-10.0.22-2.18.1
libmysqlclient18-debuginfo-10.0.22-2.18.1
libmysqlclient_r18-10.0.22-2.18.1
libmysqld-devel-10.0.22-2.18.1
libmysqld18-10.0.22-2.18.1
libmysqld18-debuginfo-10.0.22-2.18.1
mariadb-10.0.22-2.18.1
mariadb-bench-10.0.22-2.18.1
mariadb-bench-debuginfo-10.0.22-2.18.1
mariadb-client-10.0.22-2.18.1
mariadb-client-debuginfo-10.0.22-2.18.1
mariadb-debuginfo-10.0.22-2.18.1
mariadb-debugsource-10.0.22-2.18.1
mariadb-errormessages-10.0.22-2.18.1
mariadb-test-10.0.22-2.18.1
mariadb-test-debuginfo-10.0.22-2.18.1
mariadb-tools-10.0.22-2.18.1
mariadb-tools-debuginfo-10.0.22-2.18.1

- openSUSE 13.2 (x86_64):

libmysqlclient18-32bit-10.0.22-2.18.1
libmysqlclient18-debuginfo-32bit-10.0.22-2.18.1
libmysqlclient_r18-32bit-10.0.22-2.18.1


References:

https://www.suse.com/security/cve/CVE-2015-4792.html
https://www.suse.com/security/cve/CVE-2015-4802.html
https://www.suse.com/security/cve/CVE-2015-4807.html
https://www.suse.com/security/cve/CVE-2015-4815.html
https://www.suse.com/security/cve/CVE-2015-4826.html
https://www.suse.com/security/cve/CVE-2015-4830.html
https://www.suse.com/security/cve/CVE-2015-4836.html
https://www.suse.com/security/cve/CVE-2015-4858.html
https://www.suse.com/security/cve/CVE-2015-4861.html
https://www.suse.com/security/cve/CVE-2015-4870.html
https://www.suse.com/security/cve/CVE-2015-4913.html
https://bugzilla.suse.com/937787

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages