Mailinglist Archive: opensuse-security-announce (27 mails)

< Previous Next >
[security-announce] openSUSE-SU-2015:1831-1: important: Security update for haproxy
openSUSE Security Update: Security update for haproxy
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1831-1
Rating: important
References: #937042 #937202
Cross-References: CVE-2015-3281
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

haproxy was updated to fix two security issues.

These security issues were fixed:
- CVE-2015-3281: The buffer_slow_realign function in HAProxy did not
properly realign a buffer that is used for pending outgoing data, which
allowed remote attackers to obtain sensitive information (uninitialized
memory contents of previous requests) via a crafted request (bsc#937042).
- Changed DH parameters to prevent Logjam attack.

These non-security issues were fixed:
- BUG/MAJOR: buffers: make the buffer_slow_realign() function respect
output data
- BUG/MINOR: ssl: fix smp_fetch_ssl_fc_session_id
- MEDIUM: ssl: replace standards DH groups with custom ones
- BUG/MEDIUM: ssl: fix tune.ssl.default-dh-param value being overwritten
- MINOR: ssl: add a destructor to free allocated SSL ressources
- BUG/MINOR: ssl: Display correct filename in error message
- MINOR: ssl: load certificates in alphabetical order
- BUG/MEDIUM: checks: fix conflicts between agent checks and ssl
healthchecks
- BUG/MEDIUM: ssl: force a full GC in case of memory shortage
- BUG/MEDIUM: ssl: fix bad ssl context init can cause segfault in case of
OOM.
- BUG/MINOR: ssl: correctly initialize ssl ctx for invalid certificates
- MINOR: ssl: add statement to force some ssl options in global.
- MINOR: ssl: add fetchs 'ssl_c_der' and 'ssl_f_der' to return DER
formatted certs


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-682=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

haproxy-1.5.5-3.1
haproxy-debuginfo-1.5.5-3.1
haproxy-debugsource-1.5.5-3.1


References:

https://www.suse.com/security/cve/CVE-2015-3281.html
https://bugzilla.suse.com/937042
https://bugzilla.suse.com/937202

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages