Mailinglist Archive: opensuse-security-announce (53 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:1184-1: important: Security update for OpenSSL
SUSE Security Update: Security update for OpenSSL
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:1184-1
Rating: important
References: #929678 #931698 #933911 #934487 #934489 #934491
#934493
Cross-References: CVE-2015-1788 CVE-2015-1789 CVE-2015-1790
CVE-2015-1791 CVE-2015-1792 CVE-2015-3216
CVE-2015-4000
Affected Products:
SUSE Linux Enterprise Server 11 SP1 LTSS
______________________________________________________________________________

An update that fixes 7 vulnerabilities is now available. It
includes one version update.

Description:


OpenSSL 0.9.8j was updated to fix several security issues.

* CVE-2015-4000: The Logjam Attack ( weakdh.org ) has been addressed
by rejecting connections with DH parameters shorter than 1024 bits.
We now also generate 2048-bit DH parameters by default.
* CVE-2015-1788: Malformed ECParameters could cause an infinite loop.
* CVE-2015-1789: An out-of-bounds read in X509_cmp_time was fixed.
* CVE-2015-1790: A PKCS7 decoder crash with missing EnvelopedContent
was fixed.
* CVE-2015-1792: A CMS verification infinite loop when using an
unknown hash function was fixed.
* CVE-2015-1791: Fixed a race condition in NewSessionTicket creation.
* CVE-2015-3216: Fixed a potential crash in ssleay_rand_bytes due to
locking regression.
* fixed a timing side channel in RSA decryption (bnc#929678)

Additional changes:

* In the default SSL cipher string EXPORT ciphers are now disabled.
This will only get active if applications get rebuilt and actually
use this string. (bnc#931698)
* Added the ECC ciphersuites to the DEFAULT cipher class (bnc#879179)

Security Issues:

* CVE-2015-1788
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1788>
* CVE-2015-1789
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1789>
* CVE-2015-1790
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1790>
* CVE-2015-1791
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1791>
* CVE-2015-1792
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1792>
* CVE-2015-3216
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3216>
* CVE-2015-4000
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-4000>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP1 LTSS:

zypper in -t patch slessp1-libopenssl-devel=10794

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP1 LTSS (i586 s390x x86_64) [New Version:
0.9.8j]:

libopenssl-devel-0.9.8j-0.72.1
libopenssl0_9_8-0.9.8j-0.72.1
libopenssl0_9_8-hmac-0.9.8j-0.72.1
openssl-0.9.8j-0.72.1
openssl-doc-0.9.8j-0.72.1

- SUSE Linux Enterprise Server 11 SP1 LTSS (s390x x86_64) [New Version:
0.9.8j]:

libopenssl0_9_8-32bit-0.9.8j-0.72.1
libopenssl0_9_8-hmac-32bit-0.9.8j-0.72.1


References:

https://www.suse.com/security/cve/CVE-2015-1788.html
https://www.suse.com/security/cve/CVE-2015-1789.html
https://www.suse.com/security/cve/CVE-2015-1790.html
https://www.suse.com/security/cve/CVE-2015-1791.html
https://www.suse.com/security/cve/CVE-2015-1792.html
https://www.suse.com/security/cve/CVE-2015-3216.html
https://www.suse.com/security/cve/CVE-2015-4000.html
https://bugzilla.suse.com/929678
https://bugzilla.suse.com/931698
https://bugzilla.suse.com/933911
https://bugzilla.suse.com/934487
https://bugzilla.suse.com/934489
https://bugzilla.suse.com/934491
https://bugzilla.suse.com/934493

https://download.suse.com/patch/finder/?keywords=ab1c52f77471cf8a61e7eae79f57f9bf

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages