Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:1119-1: important: Security update for glibc
SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:1119-1
Rating: important
References: #772242 #779320 #818630 #828235 #828637 #834594
#892073
Cross-References: CVE-2012-4412 CVE-2013-4237 CVE-2014-5119

Affected Products:
SUSE Linux Enterprise Server 10 SP4 LTSS
______________________________________________________________________________

An update that solves three vulnerabilities and has four
fixes is now available.

Description:


This glibc update fixes a critical privilege escalation problem and the
following security and non security issues:

* bnc#892073: An off-by-one error leading to a heap-based buffer
overflow was found in __gconv_translit_find(). An exploit that
targets the problem is publicly available. (CVE-2014-5119)
* bnc#772242: Replace scope handing with master state
* bnc#779320: Fix buffer overflow in strcoll (CVE-2012-4412)
* bnc#818630: Fall back to localhost if no nameserver defined
* bnc#828235: Fix missing character in IBM-943 charset
* bnc#828637: Fix use of alloca in gaih_inet
* bnc#834594: Fix readdir_r with long file names (CVE-2013-4237)

Security Issues:

* CVE-2014-5119
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-5119>
* CVE-2013-4237
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4237>
* CVE-2012-4412
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4412>



Package List:

- SUSE Linux Enterprise Server 10 SP4 LTSS (i586 i686 s390x x86_64):

glibc-2.4-31.111.1
glibc-devel-2.4-31.111.1

- SUSE Linux Enterprise Server 10 SP4 LTSS (i586 s390x x86_64):

glibc-html-2.4-31.111.1
glibc-i18ndata-2.4-31.111.1
glibc-info-2.4-31.111.1
glibc-locale-2.4-31.111.1
glibc-profile-2.4-31.111.1
nscd-2.4-31.111.1

- SUSE Linux Enterprise Server 10 SP4 LTSS (s390x x86_64):

glibc-32bit-2.4-31.111.1
glibc-devel-32bit-2.4-31.111.1
glibc-locale-32bit-2.4-31.111.1
glibc-profile-32bit-2.4-31.111.1


References:

http://support.novell.com/security/cve/CVE-2012-4412.html
http://support.novell.com/security/cve/CVE-2013-4237.html
http://support.novell.com/security/cve/CVE-2014-5119.html
https://bugzilla.novell.com/772242
https://bugzilla.novell.com/779320
https://bugzilla.novell.com/818630
https://bugzilla.novell.com/828235
https://bugzilla.novell.com/828637
https://bugzilla.novell.com/834594
https://bugzilla.novell.com/892073

http://download.suse.com/patch/finder/?keywords=767429925ce018c15cbe14c33d6a0f11

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages