Mailinglist Archive: opensuse-security-announce (25 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:0931-1: important: Security update for libtasn1
SUSE Security Update: Security update for libtasn1
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:0931-1
Rating: important
References: #880735 #880737 #880738
Cross-References: CVE-2014-3467 CVE-2014-3468 CVE-2014-3469

Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Desktop 11 SP3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


libtasn1 has been updated to fix three security issues:

* asn1_get_bit_der() could have returned negative bit length
(CVE-2014-3468)
* Multiple boundary check issues could have allowed DoS (CVE-2014-3467)
* Possible DoS by NULL pointer dereference in asn1_read_value_type
(CVE-2014-3469)

Security Issues:

* CVE-2014-3468
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3468>
* CVE-2014-3467
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3467>
* CVE-2014-3469
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3469>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP3:

zypper in -t patch sdksp3-libtasn1-9528

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-libtasn1-9528

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-libtasn1-9528

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-libtasn1-9528

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64
s390x x86_64):

libtasn1-devel-1.5-1.28.1

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

libtasn1-1.5-1.28.1
libtasn1-3-1.5-1.28.1

- SUSE Linux Enterprise Server 11 SP3 for VMware (x86_64):

libtasn1-3-32bit-1.5-1.28.1

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

libtasn1-1.5-1.28.1
libtasn1-3-1.5-1.28.1

- SUSE Linux Enterprise Server 11 SP3 (ppc64 s390x x86_64):

libtasn1-3-32bit-1.5-1.28.1

- SUSE Linux Enterprise Server 11 SP3 (ia64):

libtasn1-3-x86-1.5-1.28.1

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):

libtasn1-1.5-1.28.1
libtasn1-3-1.5-1.28.1

- SUSE Linux Enterprise Desktop 11 SP3 (x86_64):

libtasn1-3-32bit-1.5-1.28.1


References:

http://support.novell.com/security/cve/CVE-2014-3467.html
http://support.novell.com/security/cve/CVE-2014-3468.html
http://support.novell.com/security/cve/CVE-2014-3469.html
https://bugzilla.novell.com/880735
https://bugzilla.novell.com/880737
https://bugzilla.novell.com/880738

http://download.suse.com/patch/finder/?keywords=c519e17b9f1f9f2c0888e237f0b42f05

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages