Mailinglist Archive: opensuse-security-announce (23 mails)

< Previous Next >
[security-announce] SUSE-SU-2013:1304-1: critical: Security update for puppet
SUSE Security Update: Security update for puppet
______________________________________________________________________________

Announcement ID: SUSE-SU-2013:1304-1
Rating: critical
References: #825878
Cross-References: CVE-2013-3567
Affected Products:
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP2 for VMware
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Desktop 11 SP2
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:


This puppet update fixes a remote code execution issue:

* Unauthenticated Remote Code Execution Vulnerability
with YAML and REST API calls (bug#825878, CVE-2013-3567)

Security Issue reference:

* CVE-2013-3567
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-3567
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-puppet-8132

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-puppet-8132

- SUSE Linux Enterprise Server 11 SP2 for VMware:

zypper in -t patch slessp2-puppet-8131

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp2-puppet-8131

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-puppet-8132

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp2-puppet-8131

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

puppet-2.6.18-0.6.1
puppet-server-2.6.18-0.6.1

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

puppet-2.6.18-0.6.1
puppet-server-2.6.18-0.6.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64) [New Version:
2.6.18]:

puppet-2.6.18-0.6.1
puppet-server-2.6.18-0.6.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New
Version: 2.6.18]:

puppet-2.6.18-0.6.1
puppet-server-2.6.18-0.6.1

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):

puppet-2.6.18-0.6.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64) [New Version: 2.6.18]:

puppet-2.6.18-0.6.1


References:

http://support.novell.com/security/cve/CVE-2013-3567.html
https://bugzilla.novell.com/825878

http://download.novell.com/patch/finder/?keywords=257dd8125d8a1d0ff79cfbc990fb2583

http://download.novell.com/patch/finder/?keywords=3cee502500023425010c6abfb51fa21e

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages