Mailinglist Archive: opensuse-security-announce (13 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0326-1: important: Security update for libvorbis
SUSE Security Update: Security update for libvorbis
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0326-1
Rating: important
References: #747912
Cross-References: CVE-2012-0444
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1 FOR
SP2
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1 FOR SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Desktop 11 SP1 FOR SP2
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 10 SP4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


Specially crafted Ogg files could cause a heap-based buffer
overflow in the vorbis audio compression library that
could potentially be exploited by attackers to cause a
crash or execute arbitrary code (CVE-2012-0444).

Security Issue reference:

* CVE-2012-0444
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0444
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1 FOR SP2:

zypper in -t patch sdksp1fsp2-libvorbis-5851

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libvorbis-5851

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libvorbis-5851

- SUSE Linux Enterprise Server 11 SP1 FOR SP2:

zypper in -t patch slessp1fsp2-libvorbis-5851

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libvorbis-5851

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2:

zypper in -t patch sledsp1fsp2-libvorbis-5851

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libvorbis-5851

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 FOR SP2 (i586 ia64
ppc64 s390x x86_64):

libvorbis-devel-1.2.0-79.20.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

libvorbis-devel-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

libvorbis-1.2.0-79.20.1
libvorbis-doc-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64):

libvorbis-32bit-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 FOR SP2 (i586 ia64 ppc64 s390x x86_64):

libvorbis-1.2.0-79.20.1
libvorbis-doc-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 FOR SP2 (ppc64 s390x x86_64):

libvorbis-32bit-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 FOR SP2 (ia64):

libvorbis-x86-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

libvorbis-1.2.0-79.20.1
libvorbis-doc-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64):

libvorbis-32bit-1.2.0-79.20.1

- SUSE Linux Enterprise Server 11 SP1 (ia64):

libvorbis-x86-1.2.0-79.20.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

libvorbis-1.1.2-13.19.1
libvorbis-devel-1.1.2-13.19.1

- SUSE Linux Enterprise Server 10 SP4 (s390x x86_64):

libvorbis-32bit-1.1.2-13.19.1

- SUSE Linux Enterprise Server 10 SP4 (ia64):

libvorbis-x86-1.1.2-13.19.1

- SUSE Linux Enterprise Server 10 SP4 (ppc):

libvorbis-64bit-1.1.2-13.19.1

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2 (i586 x86_64):

libvorbis-1.2.0-79.20.1

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2 (x86_64):

libvorbis-32bit-1.2.0-79.20.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

libvorbis-1.2.0-79.20.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64):

libvorbis-32bit-1.2.0-79.20.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

libvorbis-1.1.2-13.19.1
libvorbis-devel-1.1.2-13.19.1

- SUSE Linux Enterprise Desktop 10 SP4 (x86_64):

libvorbis-32bit-1.1.2-13.19.1


References:

http://support.novell.com/security/cve/CVE-2012-0444.html
https://bugzilla.novell.com/747912

http://download.novell.com/patch/finder/?keywords=56f02ce23b1f6abe181f7e00c3bc1f23

http://download.novell.com/patch/finder/?keywords=dca0a520e9ca9f5bad17b1c77fc0f1a6

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages