Mailinglist Archive: opensuse-security-announce (30 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:0979-1: important: Security update for vpnc
SUSE Security Update: Security update for vpnc
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:0979-1
Rating: important
References: #651577 #708656
Cross-References: CVE-2011-2660
Affected Products:
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update of vpnc fixes a flaw in the
modify_resolvconf_suse script that could potentially allow
remote attackers to inject commands through specially
crafted DNS domains (CVE-2011-2660).

Also a rekeying during reconnect was improved.

Security Issue reference:

* CVE-2011-2660
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2660
>

Indications:

Please install this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-vpnc-5027

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

vpnc-0.5.1-55.10.1


References:

http://support.novell.com/security/cve/CVE-2011-2660.html
https://bugzilla.novell.com/651577
https://bugzilla.novell.com/708656

http://download.novell.com/patch/finder/?keywords=6492485ec672451add947d43aec02a1b

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages