Mailinglist Archive: opensuse-security-announce (20 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:0632-1: critical: Sun/Oracle Java
SUSE Security Update: Sun/Oracle Java
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:0632-1
Rating: critical
References: #698754
Cross-References: CVE-2011-0786 CVE-2011-0788 CVE-2011-0802
CVE-2011-0814 CVE-2011-0815 CVE-2011-0817
CVE-2011-0862 CVE-2011-0863 CVE-2011-0864
CVE-2011-0865 CVE-2011-0866 CVE-2011-0867
CVE-2011-0868 CVE-2011-0869 CVE-2011-0871
CVE-2011-0872 CVE-2011-0873
Affected Products:
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 10 SP4
______________________________________________________________________________

An update that fixes 17 vulnerabilities is now available.
It includes one version update.

Description:


Oracle Java 6 Update 26 fixes several security
vulnerabilities.

Please refer to Oracle's site for further information:
http://www.oracle.com/technetwork/topics/security/javacpujun
e2011-313339.html
<http://www.oracle.com/technetwork/topics/security/javacpuju
ne2011-313339.html>

Security Issue references:

* CVE-2011-0862
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0862
>
* CVE-2011-0873
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0873
>
* CVE-2011-0815
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0815
>
* CVE-2011-0817
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0817
>
* CVE-2011-0863
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0863
>
* CVE-2011-0864
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0864
>
* CVE-2011-0802
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0802
>
* CVE-2011-0814
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0814
>
* CVE-2011-0871
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0871
>
* CVE-2011-0786
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0786
>
* CVE-2011-0788
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0788
>
* CVE-2011-0866
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0866
>
* CVE-2011-0868
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0868
>
* CVE-2011-0872
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0872
>
* CVE-2011-0867
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0867
>
* CVE-2011-0869
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0869
>
* CVE-2011-0865
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0865
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-java-1_6_0-sun-4698

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version:
1.6.0.u26]:

java-1_6_0-sun-1.6.0.u26-0.2.1
java-1_6_0-sun-alsa-1.6.0.u26-0.2.1
java-1_6_0-sun-demo-1.6.0.u26-0.2.1
java-1_6_0-sun-jdbc-1.6.0.u26-0.2.1
java-1_6_0-sun-plugin-1.6.0.u26-0.2.1
java-1_6_0-sun-src-1.6.0.u26-0.2.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64) [New Version:
1.6.0.u26]:

java-1_6_0-sun-1.6.0.u26-0.11.1
java-1_6_0-sun-alsa-1.6.0.u26-0.11.1
java-1_6_0-sun-demo-1.6.0.u26-0.11.1
java-1_6_0-sun-devel-1.6.0.u26-0.11.1
java-1_6_0-sun-jdbc-1.6.0.u26-0.11.1
java-1_6_0-sun-src-1.6.0.u26-0.11.1

- SUSE Linux Enterprise Desktop 10 SP4 (x86_64) [New Version: 1.6.0.u26]:

java-1_6_0-sun-32bit-1.6.0.u26-0.11.1
java-1_6_0-sun-plugin-32bit-1.6.0.u26-0.11.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586) [New Version: 1.6.0.u26]:

java-1_6_0-sun-plugin-1.6.0.u26-0.11.1


References:

http://support.novell.com/security/cve/CVE-2011-0786.html
http://support.novell.com/security/cve/CVE-2011-0788.html
http://support.novell.com/security/cve/CVE-2011-0802.html
http://support.novell.com/security/cve/CVE-2011-0814.html
http://support.novell.com/security/cve/CVE-2011-0815.html
http://support.novell.com/security/cve/CVE-2011-0817.html
http://support.novell.com/security/cve/CVE-2011-0862.html
http://support.novell.com/security/cve/CVE-2011-0863.html
http://support.novell.com/security/cve/CVE-2011-0864.html
http://support.novell.com/security/cve/CVE-2011-0865.html
http://support.novell.com/security/cve/CVE-2011-0866.html
http://support.novell.com/security/cve/CVE-2011-0867.html
http://support.novell.com/security/cve/CVE-2011-0868.html
http://support.novell.com/security/cve/CVE-2011-0869.html
http://support.novell.com/security/cve/CVE-2011-0871.html
http://support.novell.com/security/cve/CVE-2011-0872.html
http://support.novell.com/security/cve/CVE-2011-0873.html
https://bugzilla.novell.com/698754

http://download.novell.com/patch/finder/?keywords=338a1546773a4e28c9f256c1ad7d6c8c

http://download.novell.com/patch/finder/?keywords=6bc8d900b81c810dacee03e32dd0ee6c

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages