Mailinglist Archive: opensuse-ruby (24 mails)

< Previous Next >
[opensuse-ruby] Ruby 2.2, Tumbleweed and systemsmanagement:/puppet
  • From: Johannes Kastl <mail@xxxxxxxxxx>
  • Date: Tue, 12 May 2015 20:15:08 +0200
  • Message-id: <mitfvi$mfi$1@ger.gmane.org>
Hi there,

I just installed the latest updates on my main tumbleweed machine.
Some ruby2.2-rubygems were installed without problems, but I get the
following error:

zypper in rubygem-puppet-master
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
rubygem-puppet-master

1 new package to install.
Overall download size: 33.7 KiB. Already cached: 0 B After the operation,
additional 6.6 KiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package rubygem-puppet-master-3.7.5-2.1.x86_64
(1/1), 33.7 KiB ( 6.6
KiB unpacked)
Retrieving: rubygem-puppet-master-3.7.5-2.1.x86_64.rpm
.............................................................................................[done
(249.9 KiB/s)]
Checking for file conflicts:
.....................................................................................................................................[done]
(1/1) Installing: rubygem-puppet-master-3.7.5-2.1
................................................................................................................[done]
Additional rpm output:
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/defaults.rb:488:
warning: duplicated key at line 489 ignored: :queue_type
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor/safe_yaml/lib/safe_yaml/syck_node_monkeypatch.rb:42:in
`<top (required)>': uninitialized constant Syck (NameError)
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb:197:in
`<module:YAML>'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb:132:in
`<top (required)>'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor/require_vendored.rb:4:in
`<top (required)>'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor.rb:40:in
`require_libs'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/vendor.rb:53:in
`load_vendored'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet.rb:172:in
`<module:Puppet>'
from /usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet.rb:29:in
`<top (required)>'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from
/usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/lib/puppet/util/command_line.rb:12:in
`<top (required)>'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
`require'
from /usr/lib64/ruby/gems/2.2.0/gems/puppet-3.7.5/bin/puppet:7:in
`<top (required)>'
from /usr/bin/puppet:23:in `load'
from /usr/bin/puppet:23:in `<main>'

I have added the puppet repo recently (systemsmanagement:/puppet/),
maybe this is the reason for the error?

I'll disable it and test again.

Johannes

< Previous Next >