Mailinglist Archive: opensuse-ruby (24 mails)

< Previous Next >
Re: [opensuse-ruby] ruby 2.2 - next step
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06.05.2015 12:45, Josef Reidinger wrote:


That do not work, as Yast do not know which rubygem it need. It
need rubygem for ruby used as systemwide one. So if system ruby is
2.2 it need 2.2 gem. If system ruby is 2.1 it need 2.1. I hope that
it is handled automatic with `rubygem()` dependency. I see no way
how we can do it with fixed version.


How do you define as "system ruby"? /usr/bin/ruby is the default ruby
of the distribution - all other ruby versions require you to call
ruby2.1 or ruby2.2 and yast2-ruby-bindings requires the ruby it was
compiled with.

This is what yast2-storage should do too IMO, but possibly there are
better alternatives.

Greetings, Stephan

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlVJ9m4ACgkQwFSBhlBjoJZONQCfTZor0jWZhssxhpPvXz3NMD5q
TKEAoM4dvMMIjHCpMkXDHI0ElLhziSMj
=AqiL
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation