Mailinglist Archive: opensuse-ruby (16 mails)

< Previous Next >
Re: [opensuse-ruby] Re: Funny thing with rubygem dependencies
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Wed, 21 May 2014 20:24:37 +0100
  • Message-id: <20140521192436.GB27261@pacific.linksys.moosehall>
Johannes Kastl (mail@xxxxxxxxxx) wrote:
On 21.05.2014 19:57 Josef Reidinger wrote:

actually no, as require is rubygem(2.0.0:liquid:2.5)

Sorry, I'm confused. Does your 'no' mean the dependency is not

Yes, it is not satisfied; as Josef already said, liquid 2.6.1 does not
satisfy the requirement for rubygem(2.0.0:liquid:2.5) >= 2.5.5.

And: I added an (additional?) dependency in the spec myself like this,
to see if it would work out:

Requires: rubygem-liquid >= 2.5.5

Adding additional dependencies will not cause existing ones to be

But I guess somewhere in the build, a dependecy is added that results
in the 'rubygem(2.0.0:liquid:2.5)'.

Correct. This is all explained here:

To cut a long story short, other than downgrading liquid, how can I
get jekyll to install?

I presume you want a *working* install not just an install[0], in
which case you need to install a version of rubygem-liquid which
satisfies the ~> 2.5.5 requirement. "osc se -V rubygem-liquid"
suggests that there is no such version available in OBS, which leads
me to suspect that it may have been broken by:

So you can either build one yourself, or ask nicely for someone else
to fix it. The best way to do the latter is probably by clicking the
"Report Bug" link from

[0] If you only want the latter, you could force it to ignore the

To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups