Mailinglist Archive: opensuse-ruby (16 mails)

< Previous Next >
Re: [opensuse-ruby] Re: Funny thing with rubygem dependencies
On Wed, 21 May 2014 21:00:20 +0200
Johannes Kastl <mail@xxxxxxxxxx> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 21.05.2014 19:57 Josef Reidinger wrote:

actually no, as require is rubygem(2.0.0:liquid:2.5)

Sorry, I'm confused. Does your 'no' mean the dependency is not
satisfied? Or does it mean I'm missing nothing?

no means, that dependency is not satisfied


And: I added an (additional?) dependency in the spec myself like this,
to see if it would work out:

Requires: rubygem-liquid >= 2.5.5

But I guess somewhere in the build, a dependecy is added that results
in the 'rubygem(2.0.0:liquid:2.5)'.

yes, it is automatic grabbed from gem specification -
https://github.com/jekyll/jekyll/blob/master/jekyll.gemspec#L31


To cut a long story short, other than downgrading liquid, how can I
get jekyll to install?

You need to install liquid that have version between 2.5.5 and
2.5.9999999 ( in short lower then 2.6.0 )

If you read url I write in my email you understand what "liquid ~>
2.5.5" specified for jekyll means.

Josef


Regards,
Johannes
- --
`You should write a book,´ Ron told Hermione as he cut up his
potatoes, `translating mad things girls do so boys can understand
them.´ (Harry Potter and the Order of the Phoenix)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with SeaMonkey - http://www.enigmail.net/

iEYEARECAAYFAlN898QACgkQzi3gQ/xETbLvsgCaA0h5g6xHLyhNBMqPV7IWkwn2
FoAAnimR0SFZQuXaOgQPJ0mIgiM68wTl
=+6bQ
-----END PGP SIGNATURE-----


--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >