Mailinglist Archive: opensuse-ruby (16 mails)

< Previous Next >
[opensuse-ruby] Funny thing with rubygem dependencies
  • From: Johannes Kastl <mail@xxxxxxxxxx>
  • Date: Wed, 21 May 2014 19:52:00 +0200
  • Message-id: <llip40$sho$1@ger.gmane.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi everyone,

I have a funny issue with a dependency from a rubygem, depending on
another rubygem:

$ LANG=POSIX sudo zypper in rubygem-jekyll Loading repository
data... Reading installed packages... Resolving package
dependencies...

Problem: nothing provides rubygem(2.0.0:liquid:2.5) >= 2.5.5 needed
by rubygem-jekyll-2.0.3-3.2.x86_64 Solution 1: do not install
rubygem-jekyll-2.0.3-3.2.x86_64 Solution 2: break
rubygem-jekyll-2.0.3-3.2.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/c] (c): ^C $
LANG=POSIX sudo zypper in rubygem-liquid Loading repository
data... Reading installed packages... Resolving package
dependencies...

The following NEW package is going to be installed: rubygem-liquid


1 new package to install. Overall download size: 76.0 KiB. After
the operation, additional 116.3 KiB will be used. Continue? [y/n/?
shows all options] (y): ^C

So jekyll depends on liquid, and I can install liquid. liquid is
version 2.6.1, so it should satisfy jekyll's dependency on liquid
=2.5.5? Or am I missing something?

$ LANG=POSIX zypper se --detail rubygem-liquid Loading repository
data... Reading installed packages...

S | Name | Type | Version | Arch |
Repository
--+--------------------------+------------+-----------+--------+----------------------------------------


i | rubygem-liquid | package | 2.6.1-3.1 | x86_64 |
ojkastl_buildservice:Testing_Tumbleweed
v | rubygem-liquid | package | 2.6.1-3.1 | i586 |
ojkastl_buildservice:Testing_Tumbleweed | rubygem-liquid
| srcpackage | 2.6.1-3.1 | noarch |
ojkastl_buildservice:Testing_Tumbleweed | rubygem-liquid-doc
| package | 2.6.1-3.1 | x86_64 |
ojkastl_buildservice:Testing_Tumbleweed | rubygem-liquid-doc
| package | 2.6.1-3.1 | i586 |
ojkastl_buildservice:Testing_Tumbleweed | rubygem-liquid-testsuite
| package | 2.6.1-3.1 | x86_64 |
ojkastl_buildservice:Testing_Tumbleweed | rubygem-liquid-testsuite
| package | 2.6.1-3.1 | i586 |
ojkastl_buildservice:Testing_Tumbleweed

But even after installing liquid beforehand I still get the error. Any
hints?

Regards,
Johannes
- --
"And trust no-- Trust practically no-one. All right? Except
trustworthy people."
(Terry Pratchett: Jingo)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with SeaMonkey - http://www.enigmail.net/

iEYEARECAAYFAlN858AACgkQzi3gQ/xETbJLzACeJcOPZ9B8EREX0N2voH6ktgkp
rzQAnRwf4LtM1z+9rqVQ9LS+xcpCEfcJ
=zDs8
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups