Mailinglist Archive: opensuse-ruby (69 mails)

< Previous Next >
Re: [opensuse-ruby] A new packaging scheme for Ruby 2.1
* Jordi Massaguer Pla <jmassaguerpla@xxxxxxx> [Jan 22. 2014 13:52]:

On 01/22/2014 01:23 PM, Klaus Kaempf wrote:
Hi,

going forward, Ruby becomes more important in the openSUSE and SLES
codebase. This is why Coolo asked me to come up with a new Ruby
packaging scheme. Read on to learn about my current thinking in this
regard.

What are the goals ?

1. revert the ruby, rubyXY, and ruby-common split
Initially done to allow multiple Ruby versions in parallel, it
wasn't really used and developers use rvm or rbenv to achieve the
same effect.
From a buildservice perspective, this split cause more headaches
than it provided value.

in studio product we have ruby 1.8 and ruby 1.9 at the same time
because the first one is a requirement from WebYast and the second
one from studio itself. I am not saying this is good or desirable,
but please take in mind this kind of situation.

The new packaging scheme will be applied from Ruby-2.1 on forward. It
should not affect previous distributions.

Otoh, having a single Ruby version will prevent such crazy setups as
above in the future ;-)

Klaus
--
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB
16746 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation