Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] gems on SP2
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Fri, 30 Nov 2012 10:45:43 +0000
  • Message-id: <20121130104543.GF22090@pacific.linksys.moosehall>
Josef Reidinger (jreidinger@xxxxxxx) wrote:
On Thu, 29 Nov 2012 17:13:33 +0100
"Bernhard M. Wiedemann" <bwiedemann@xxxxxxx> wrote:
I found that when installing
https://build.opensuse.org/package/show?package=rubygem-net-ssh&project=devel%3Alanguages%3Aruby%3Aextensions

on SLE-11-SP2 it does not pull in the rubygems package as a dependency
and thus fails to work. I guess the easy fix is to add to the
dependency-generator-output:
%if 0%{?suse_version} && 0%{?suse_version} < 1130
Requires: rubygems
%endif

I think you should add it unconditionally, because on newer
systems ruby 1.9 already provide rubygems, so it is correctly matched.

+1. coolo, any objections if we add this to rubygemsdeps.rb?
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups