Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] Revised gem packaging
* Stephan Kulow <coolo@xxxxxxx> [Nov 05. 2012 20:13]:


https://build.opensuse.org/package/view_file?file=sblim-sfcb.spec&package=sblim-sfcb-sle11-sp1&project=systemsmanagement%3Awbem

https://build.opensuse.org/package/view_file?file=sblim-sfcb.spec&package=sblim-sfcb-sle11-sp2&project=systemsmanagement%3Awbem

Well, what will happen if you buildrequire sblim-sfcb? I can tell you:
the last built rpm will win -> not good

I cannot imagine that the BuildRequires solver will choose the _last
built_ package.
I'd expect it to choose the 'best' package (best architecture, best
version)

, especially if it's important
that the rpm has a specific version.

And that's exactly the point with building rubygems. You _need_ to
specify exact versions of your build dependencies. -> Problem solved

Klaus
--
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB
16746 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation