Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] .gitignore in gems
On 04.11.2012 19:39, Adam Spiers wrote:
I noticed that the rubygem-rainbows gem contains three .gitignore
files, which cause rpmlint warnings. I'm guessing there are other
gems out there with the same problem. Would it make sense to fix this
by adding something like

find $RPM_BUILD_ROOT -name .gitignore | xargs -n rm

to /usr/lib/rpm/gem_install_wrapper.sh?

The danger is that there might be an occasion where there was a real
need for a gem rpm to include a .gitignore file.

The alternatives are:

- try to get the upstream gem fixed, or

- do the same .gitignore removal in each .spec file, which is
annoying and potentially repetitive.

As there are 241 gems that show that warning, I would say it's a good
idea to centralize the fix.

I can't think of a reason to keep the .gitignore in the installed gem.

Greetings, Stephan

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References