Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] Revised gem packaging
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Sat, 3 Nov 2012 14:01:25 +0000
  • Message-id: <20121103140125.GC15378@pacific.linksys.moosehall>
Stephan Kulow (coolo@xxxxxxx) wrote:
Am 02.11.2012 13:40, schrieb Adam Spiers:

Ah, that's handy. So if the OBS does not have a limitation on
multiple versions of a package co-existing in a single project, I'm
even more mystified why there was ever a need to introduce the

Name: rubygem-foo-1_1

style of naming ...

Because that was used to implement foo ~> 1.1.2

But isn't that already supported via the automatic provides:

Provides: rubygem-foo-1_1 = 1.1.3

and the corresponding automatic requires:

Requires: rubygem-foo-1_1 >= 1.1.2

?

Is it just a historical thing which happened before your revamp
introduced the automatic provides/requires?
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation