Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] Revised gem packaging
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Thu, 1 Nov 2012 17:43:49 +0000
  • Message-id: <20121101174349.GA24382@pacific.linksys.moosehall>
Adam Spiers (aspiers@xxxxxxxx) wrote:
Stephan Kulow (coolo@xxxxxxx) wrote:
The automatic provides cover the old names, but I kind of hope we can
drop them in the future:

rubygem(1.9.1:rails) = 3.2.7
rubygem(rails) = 3.2.7
rubygem-rails = 3.2.7
rubygem-rails-3 = 3.2.7
rubygem-rails-3_2 = 3.2.7
rubygem-rails-3_2_7 = 3.2.7

These also seem to solve the ~> problem, since

foo ~> 1.2.3

translates to

Requires: rubygem-foo-1.2 >= 1.2.3

but that suggests that the automatic provides should not be dropped.

Whoops, that should have read

Requires: rubygem-foo-1_2 >= 1.2.3
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation