Mailinglist Archive: opensuse-ruby (15 mails)

< Previous Next >
[opensuse-ruby] -rvendor-specific doesn't exist in ruby 1.9 in Factory
Hi All,

The devel:languages:ruby:extensions/ruby-fcgi build is failing ATM because:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.vtRX8Z
...
+ ruby -rvendor-specific install.rb config
/usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot
load such file -- vendor-specific (LoadError)
from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'

Our ruby 1.8 supported -rvendor-specific, but 1.9 apparently does not.
Do we need this? Or can I just get rid of the "-rvendor-specific" bits
from the ruby-fcgi spec file?

(I'm not familiar with this option...)

Thanks,

Tim
--
Tim Serong
Senior Clustering Engineer
SUSE
tserong@xxxxxxxx
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups