Mailinglist Archive: opensuse-ruby (32 mails)

< Previous Next >
Re: [opensuse-ruby] RFC: Have 1.8 and 1.9 gems in one package
On 12.03.2012 10:38, Klaus Kaempf wrote:
* Flavio Castelli <fcastelli@xxxxxxxx> [Mar 12. 2012 10:29]:
On 03/11/2012 11:16 AM, Stephan Kulow wrote:
1. Most of the executables are just wrappers for the real stuff
happening in ruby modules, so just package the executables for the
default ruby version.
2. add a suffix to the non-default ruby versions
3. add a suffix to all executables and provide update-alternative hooks
all around
4. even more complex stuff :)

I think the 3rd solution is the best one. The 1st one sounds like
the easiest one, but as you said it doesn't work on all cases.

Ugh.

Can we please get over it and accept that Ruby 1.9 is the official
version now ?
Just to put this in the archive too: rails 2.3 has at least one problem
with ruby 1.9 that is no longer going to be fixed upstream - so ditching
1.8 also means ditching rails 2.3 (or getting maintenance of it on our
own shoulders exclusively).

Fortunately for most things there will be patches around, just as for
the problem I encountered with rails:
https://github.com/jescalante/rails/commit/6e20c3f895563280e6e8fb14ab9047d5064bbcf0

Greetings, Stephan



--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups