Mailinglist Archive: opensuse-releaseteam (19 mails)

< Previous Next >
Re: [opensuse-releaseteam] Newer version of libsolv-tools required on packagelists for repo-checker
  • From: Jimmy Berry <jberry@xxxxxxxx>
  • Date: Wed, 16 Aug 2017 11:36:22 -0500
  • Message-id: <2259368.egMC2FlfiB@boomba.local>
On Wednesday, August 16, 2017 3:25:40 AM CDT Ludwig Nussel wrote:
Jimmy Berry wrote:
[...]
On a more general note this is likely to reoccur when new features are
introduced into rpm and used in Factory as the packagelists machine will
always be using trailing versions of libsolv. As such it might make more
sense to run the repo-checker within a docker container running the
latest Tumbleweed snapshot to ensure access to the latest underlying
tooling. Any opinions on doing this? I'll file an issue in
osc-plugin-factory to track discussion.

With the rpm package built that contains the repo-checker it should not be
hard to run things in a docker container.

A simple chroot or systemd machined mananged chroot should suffice too.
I guess we'd need a proper testsuite fist to make sure results are not
unintentionally influenced by changes in Tumbleweed.

chroot containing entire distribution or just a couple tool updates?

A test suite would be nice, but the alternative is the tool unintentionally
fails due to changes introduced in Tumbleweed.


What is the workflow for updating the packagelists machine?

Asing infra probably.

Submitted ticket #90566.

--
Jimmy

--
To unsubscribe, e-mail: opensuse-releaseteam+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-releaseteam+owner@xxxxxxxxxxxx

< Previous Next >