Mailinglist Archive: opensuse-project (35 mails)

< Previous Next >
Re: [opensuse-project] Re: [opensuse-factory] openSUSE Leap's Next Major Version Number
  • From: Richard Brown <RBrownCCB@xxxxxxxxxxxx>
  • Date: Mon, 24 Apr 2017 14:18:14 +0200
  • Message-id: <CAA0b23xxZVVRH=kn8UQKGXeYSrurRcv6F97M_s1bwFQNGOGhYw@mail.gmail.com>
On 24 April 2017 at 13:08, Carlos E. R. <robin.listas@xxxxxxxxxxxxxx> wrote:

Yes, I understand that, but one of the benefits of this change means
you'll be able to get rid of some of those conditionals when Leap 42.3
reaches end of life, as opposed to needing to keep conditionals around
for 4x.y forever

No, externals have to consider old versions for many years. There are
people still using 10.3, for instance. Some one might try to install
Chrome on 42.3 and the script think it is more recent than 18.2

Um, nope.

The whole point of having a clear support lifecycle is to manage and
mitigate the long term implications of what the Project has to
support.

It also exists to set the expectations of the people using our
distributions so they can make reasonable decisions as to their use of
the distributions.

Of course people can go and choose to ignore that and use stuff that
is unsupported. But that's the point, it's unsupported.

There is no way the openSUSE Project should spend any time at all
worrying about a version that has been long unsupported, like 10.3.

It's a risk people should keep in mind when running unsupported
versions. If Leap 15 is going to be a problem for Leap 42.x users
after Leap 42.x is no longer supported, then they shouldn't run it
when it's no longer supported.

Or to put it another way - openSUSE will not support versions that are
unsupported.
--
To unsubscribe, e-mail: opensuse-project+unsubscribe@xxxxxxxxxxxx
To contact the owner, email: opensuse-project+owner@xxxxxxxxxxxx

< Previous Next >