Mailinglist Archive: opensuse-packaging (66 mails)

< Previous Next >
Re: [opensuse-packaging] Trying to package pi-hole for arm boards
Hi Paul,

Paul Gonin <paul.gonin@xxxxxxxxx> writes:

Hi !

I started a new project to build pi-hole packages for arm boards
(armv7l & aarch64)

I found packages built in a personal space, but those are only
available for x86 (and i586)
https://build.opensuse.org/package/show/home:Smar:pi-hole/pi-hole

So I branched it and enabled armv7l & aarch64
https://build.opensuse.org/project/show/home:paulgonin:branches:home:Smar:pi-hole

I am puzzled by the results. The builds succeeded on some cases
tumbleweed armv7l & aarch64 as well as SLE15SP1 aarch64... but failed
on Leap15.1 armv7l & aarch64 and SLES15SP1 armv7l
Apparently some packages are 'unresolvable'. (nothing provides
sususer-tools, rpm-build & gcc-PIE). I checked from a rpi2 with
Leap15.1 and those packages are available (with zypper se)

The issue that you are seeing is caused by your repositories being
invalid: for Leap armv7l and aarch64 binaries are published via the
"ports" repo and not via "standard". Also, SLE does not support armv7l,
so you won't be able to resolve anything for that combination ;-)


Hope this helps,

Dan

--
Dan Čermák <dcermak@xxxxxxxx>
Software Engineer Development tools
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5
90409 Nuremberg
Germany

(HRB 36809, AG Nürnberg)
Managing Director: Felix Imendörffer
< Previous Next >
This Thread
References