Mailinglist Archive: opensuse-packaging (66 mails)

< Previous Next >
Re: [opensuse-packaging] unresolvable, but binaries have been built?
Am Mon, 11 May 2020 09:32:40 +0200
schrieb Adrian Schröter <adrian@xxxxxxx>:

On Montag, 11. Mai 2020, 09:20:47 CEST wrote Detlef Steuer:
Hi!

I'm in the process to bring all of CRAN (cran.r-projet.org) into
OBS.

On Saturday night I started a mass upload of packages that
had been built successfully on my local machine.

The test repository is home:dsteuer:AutomaticCRAN

Now, a few thousand packages later nearly all packages are in
state unresolvable. A lot because they refer to other unresolvables.
That part is easy to understand.

But there are many, many packages, i.e. R-abnormality,
which say "unresolvable" but have binaries available, obviously
built after upload.

That one has also a choice error. OBS is not guessing, but
wants to have the dependency explicit (to avoid that every
build may use a different one).

Sure.


Either add one of the choices explicit to your BuildRequires:
in spec file or work with prjconf and add

Prefer: perl-XML-Twig

here for example. However, in this special case, I wonder why
R-gdata is providing this. sounds like a packaging bug which
also could cause trouble later on.


Uhh. Really, deep down in the source that package tries to install
some Perl Modules. And locally everything worked for a while
because I reused the build environment and gdata was not there in the
beginning.

Thank you for the hint.

Furthermore they refer to things not mentioned in the spec
file. In this case: "have choice for perl(XML::Twig) needed by
perl-Net-DBus: R-gdata perl-XML-Twig"

Neither perl(XML::Twig) nor R-gdata are needed for R-abnormality.

perl-Net-DBus is requiring it. You can debug this via


Ok, R-gdata needs some special treatment :-) First is "removal".

Thx again
Detlef

# osc buildinfo -d home:dsteuer:AutomaticCRAN R-abnormality
openSUSE_Leap_15.2 x86_64

for example.

Probably I'm missing something simple.

And for future attempte: If I do a local osc build and that works
just fine, is it wrong to simply assume it will work on the server?


yes, it should work there as well.

But you see atm the same error using "osc buildinfo", so a local build
won't start. (there can be a time gap, because buildinfo shows the
current result, but the server the last state when visiting the repo)


Oh, yes, I see it now, but I didn't see it, when I built using same
sources on Saturday.




All in all there will be 16000 packages uploaded in the end, I hope.

Regards
Detlef




--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >