Mailinglist Archive: opensuse-packaging (104 mails)

< Previous Next >
Re: [opensuse-packaging] %fdupes not expanding correctly
On Wed, Aug 08, 2018 at 03:11:04PM +0200, John Paul Adrian Glaubitz wrote:
Hi!

I have tried to use the %fdupes macro in my aws-sdk-cpp package [1]:

Index: aws-sdk-cpp.spec
===================================================================
--- aws-sdk-cpp.spec (revision 27e40ee71aa9d59fa4dc57c72b2b274f)
+++ aws-sdk-cpp.spec (working copy)
@@ -52,7 +52,7 @@
low- and high-level SDKs, while minimizing dependencies and providing
platform
portability (Windows, OSX, Linux, and mobile).

-This package contains the shared libaries.
+This package contains the shared libraries.

%package devel
Summary: AWS SDK for C++ - development files
@@ -86,7 +86,7 @@

%files devel
%defattr(-,root,root)
-%{_includedir}/aws/
-%{_libdir}/cmake/
-%{_libdir}/pkgconfig/
+%{_includedir}/aws
+%fdupes -s %{_libdir}/cmake
+%{_libdir}/pkgconfig
%changelog

However, when I try to build the package, the %fdupes macro is not expanding
correctly and I get the following mess:

%fdupes is a macro that is multiple lines of commands, it is not supposed to
be in the %files section, but in the %install section.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >